geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jacek Laskowski" <ja...@laskowski.net.pl>
Subject Re: Problems using openJPA
Date Mon, 09 Jul 2007 09:48:37 GMT
On 7/9/07, Ueberbach, Michael <michael.ueberbach@dbh.de> wrote:

> 23:38:42,637 ERROR [OpenEJB] The bean instances business method encountered
> a system exception: Could not locate metadata for the class using alias
> "Person". This could mean that the OpenJPA enhancer or load-time weaver was
> not run on the type whose alias is "Person". Registered alias mappings:
> "{Person=null}"
...
> First this one while deploying (coming a lot of times):
> 23:31:35,979 WARN  [Runtime] The property named
> "openjpa.ClassTransformerOptions" was not recognized and will be ignored,
> although the name closely matches a valid property called
> "openjpa.ClassResolver".

Ignore it.

> 23:38:41,410 WARN  [Enhance] An exception was thrown while attempting to
> perform class file transformation on
> "de/lama/sample3/stammdaten/ejb/PersonBean":
>
> <1.0.0-SNAPSHOT-SNAPSHOT nonfatal user error>
> org.apache.openjpa.util.UserException: Type
> "de.lama.sample3.stammdaten.ejb.PersonBean" attempts to use
> both field and property access. Only one access method is permitted.

That's the culprit. Could you publish the entity jar you deployed to
Geronimo. I think that Geronimo doesn't add much to it - OpenJPA (the
default JPA provider) can't do its job and complains and so does
Geronimo.

Jacek

-- 
Jacek Laskowski
http://www.JacekLaskowski.pl

Mime
View raw message