geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ys...@symcor.com
Subject Re: Can db2java-1.2.zip not be used to create DataSource in Geronimo 1.1.1?
Date Thu, 14 Jun 2007 16:13:48 GMT
We are trying to migrate the web application written for WebSphere 4.0 to
Geronimo 1.1.1.  Back then we had to use DB2 JDBC Driver 1.2 which type 2
driver.  It comes as db2java.zip or db2java-1.2.zip.  I have tried the jar
file format and got the same error message.

I have a out-of-box geronimo 1.1.1 and removed db2/db2jcc/1.3 from the
repository.  I only try to get the
COM.ibm.db2.jdbc.DB2ConnectionPoolDataSource working instead of
com.ibm.db2.jcc.DB2Driver (from db2jcc-1.3.jar) for successful test
connection in database pool wizard.

Thanks in advance.

Young



                                                                           
             Matt Hogstrom                                                 
             <matt@hogstrom.or                                             
             g>                                                         To 
                                       user@geronimo.apache.org            
             06/14/2007 11:42                                           cc 
             AM                                                            
                                                                   Subject 
                                       Re: Can db2java-1.2.zip not be used 
             Please respond to         to create DataSource in Geronimo    
             user@geronimo.apa         1.1.1?                              
                  che.org                                                  
                                                                           
                                                                           
                                                                           
                                                                           
                                                                           




I'm not familiar with the jcc driver version numbers.  Is 1.2 and 1.3
your version?  I thought they generally corresponded to the DB2
version being used.

Also, I assume this is a Type 4 driver, is this correct?

On Jun 14, 2007, at 10:51 AM, yskim@symcor.com wrote:

> I have taken out db2/db2jcc/1.3 from the repository by rm command
> in the
> Solaris and installed db2java-1.2.zip into the repository the
> console menu
> of Common Libs.
>
> With the use of database wizard, I have entered the database
> connection
> information and then clicked "Test Connection" before deployment.  The
> class cast exception is thrown as below.  Am I supposed to use
> db2jcc-1.3.jar only?
>
> Implementation Class in db2java-1.2.zip is
> COM.ibm.db2.jdbc.DB2ConnectionPoolDataSource.  db2jcc-1.3.jar has
> com.ibm.db2.jcc.DB2Driver.


Mime
View raw message