geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From vineetc <vinicha...@gmail.com>
Subject Re: Problems with AMQ RA under Geronimo MDB container
Date Wed, 20 Jun 2007 18:48:02 GMT

Well i did a small test of 1000 messages and it worked.

Heres what i did.
I sent a 1000 messages without the EAR running.
I configured the ThreadPool on RA to have 60 threads instead of 30.
So effectively making it twice the number of "maxSessions" value under AMQ.
I did not factor in "maxMessagesPerSession" value which to me looks like is
used to maintain a buffer of messages in RAM.
I am not too sure if 900 x 2 or 900 x 2 x 30 is the right number
But with the change i made things worked perfectly.
I also observed from JConsole that the Thread Pool never created more than
33 Threads.
Which makes me feel like it just needs some extra threads and not
necessarily 2ice.
But then i could be wrong.

I want to do more extensive testing with different configurations.
Will post my results on this thread once done.

Thanks a bunch for the observation.
I was blocked on this one just like a THREAD...lol and really didnt have
much time at hand to get into the Geronimo or AMQ code.

Vineet



On Jun 20, 2007, at 2:22 PM, vineetc wrote:

>
> I can try that.
> BTW what makes you feel it needs twice the Threads as number of  
> Sessions?

It looks to me as if all the threads came out of the pool and are  
trying to do amq work and are blocked looking for an additional  
thread.  It's entirely possible we have misunderstood the effect of  
the amq settings and it really needs 900 X 2 or 900 X 29 X 2  
threads....  If you make the settings lower do messages start flowing?

I'm just guessing :-(

thanks
david jencks
-- 
View this message in context: http://www.nabble.com/Problems-with-AMQ-RA-under-Geronimo-MDB-container-tf3954028s134.html#a11219866
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message