geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vadim Dmitriev <dmgl...@mail.ru>
Subject Geronimo eclipse plugin v2.0.0 - WTP v2.0m6 compatibility
Date Sun, 06 May 2007 00:05:10 GMT
Hi!
WTP 2.0 since milestone 6 release have version of 2.0.0 (instead of
1.6.0 for m5 and earlier). In hope to use geronimo 1.1.1 with WTP2.0m6
(this tasty JSF Tools 1.0.... :) ) i manually changed eclipse plugin
dependency from WTP 1.6.0 to 2.0.0 and everything worked fine so far
with plugin posted on 2007-03-27.
When i installed driver dated 2007-04-30 (and again made it compatible
with WTP2.0m6) i got exception on trying to create ejb project:


java.lang.ExceptionInInitializerError
    at
org.openejb.xml.ns.openejb.jar.impl.JarPackageImpl.init(JarPackageImpl.java:385)
    at
org.openejb.xml.ns.openejb.jar.JarPackage.<clinit>(JarPackage.java:150)
    at
org.apache.geronimo.st.v11.core.operations.V11DeploymentPlanCreationOperation.createOpenEjbDeploymentPlan(V11DeploymentPlanCreationOperation.java:144)
    at
org.apache.geronimo.st.core.operations.DeploymentPlanCreationOperation.execute(DeploymentPlanCreationOperation.java:72)
    at
org.apache.geronimo.st.core.operations.DeploymentPlanCreationOperation.execute(DeploymentPlanCreationOperation.java:60)
    at
org.apache.geronimo.st.core.GeronimoFacetInstallDelegate.execute(GeronimoFacetInstallDelegate.java:48)
    at
org.eclipse.wst.common.project.facet.core.internal.FacetedProject.callDelegate(FacetedProject.java:1224)
    at
org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modifyInternal(FacetedProject.java:415)
    at
org.eclipse.wst.common.project.facet.core.internal.FacetedProject.access$2(FacetedProject.java:288)
    at
org.eclipse.wst.common.project.facet.core.internal.FacetedProject$1.run(FacetedProject.java:270)
    at
org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1797)
    at
org.eclipse.wst.common.project.facet.core.internal.FacetedProject.modify(FacetedProject.java:280)
    at
org.eclipse.wst.common.componentcore.internal.operation.FacetProjectCreationOperation.addDefaultFacets(FacetProjectCreationOperation.java:133)
    at
org.eclipse.wst.common.componentcore.internal.operation.FacetProjectCreationOperation.execute(FacetProjectCreationOperation.java:106)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl$1.run(DataModelPausibleOperationImpl.java:376)
    at
org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1797)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:401)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:352)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.doExecute(DataModelPausibleOperationImpl.java:242)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.executeImpl(DataModelPausibleOperationImpl.java:214)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.cacheThreadAndContinue(DataModelPausibleOperationImpl.java:89)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.execute(DataModelPausibleOperationImpl.java:202)
    at
org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.createVirtualComponent(J2EEArtifactImportOperation.java:89)
    at
org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.doExecute(J2EEArtifactImportOperation.java:76)
    at
org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.execute(J2EEArtifactImportOperation.java:51)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl$1.run(DataModelPausibleOperationImpl.java:376)
    at
org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1797)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:401)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:352)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.doExecute(DataModelPausibleOperationImpl.java:242)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.executeImpl(DataModelPausibleOperationImpl.java:214)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.cacheThreadAndContinue(DataModelPausibleOperationImpl.java:89)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.execute(DataModelPausibleOperationImpl.java:202)
    at
org.eclipse.jst.j2ee.internal.archive.operations.EARComponentImportOperation.doExecute(EARComponentImportOperation.java:121)
    at
org.eclipse.jst.j2ee.internal.archive.operations.J2EEArtifactImportOperation.execute(J2EEArtifactImportOperation.java:51)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl$1.run(DataModelPausibleOperationImpl.java:376)
    at
org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1797)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:401)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.runOperation(DataModelPausibleOperationImpl.java:352)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.doExecute(DataModelPausibleOperationImpl.java:242)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.executeImpl(DataModelPausibleOperationImpl.java:214)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.cacheThreadAndContinue(DataModelPausibleOperationImpl.java:89)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.DataModelPausibleOperationImpl.execute(DataModelPausibleOperationImpl.java:202)
    at
org.eclipse.wst.common.frameworks.internal.datamodel.ui.DataModelWizard$1$CatchThrowableRunnableWithProgress.run(DataModelWizard.java:211)
    at
org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:113)
Caused by: java.lang.ClassCastException:
org.apache.geronimo.xml.ns.security.impl.SecurityPackageImpl cannot be
cast to org.apache.geronimo.xml.ns.security.SecurityPackage
    at
org.openejb.xml.ns.openejb.jar.impl.JarPackageImpl.initializePackageContents(JarPackageImpl.java:2188)
    at
org.openejb.xml.ns.pkgen.impl.PkgenPackageImpl.init(PkgenPackageImpl.java:170)
    at org.openejb.xml.ns.pkgen.PkgenPackage.<clinit>(PkgenPackage.java:61)
    ... 45 more


I just want to know if somebody used latest driver posted on geronimo's
site with wtp2.0m6 successfully, and i simply messed up something in my
eclipse installation :)

Thanks!

Mime
View raw message