geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jmdev <>
Subject Problems Using ActiveMQ 4.1.0 with Geronimo 1.1.1
Date Thu, 03 May 2007 20:26:28 GMT

Not sure if I can do this, but I wanted to use ActiveMQ v4.1.0 with Geronimo
1.1.1.  I have attempted both an MDB and an MDP (leveraging Spring 2.0
inside a WAR).  In both cases, I am getting the dreaded Wire Format
Negotiation error when a connection is attempted with the broker.  I
understand that this error is caused by using incompatible versions of

I thought that I could use <hidden-classes> for org.apache.activemq and
org.activemq, but I am still getting the error.  If I run a stand alone
client with the same version of ActiveMQ 4.1.0, I have no problems
connecting to my broker.

Is there something in Geronimo that is preventing this from working even
though I have defined hidden-classes?

I know that Geronimo > 1.2 is using the updated version of ActiveMQ, but for
this project, we are required to use 1.1.1.

View this message in context:
Sent from the Apache Geronimo - Users mailing list archive at

View raw message