geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arinté" <arint...@gmail.com>
Subject Re: Sun Jsf and Geronimo
Date Tue, 24 Apr 2007 03:47:05 GMT
I have tried installing the jsf files through geronimo and including in the 
war file and they both give the same error.

"Paul McMahan" <paulmcmahan@gmail.com> wrote 
in message news:085E1C12-985A-406F-B66A-384548B96B7C@gmail.com...
Hello,  How are you trying to use the sun jsf impl?  For example are
you including it in your WEB-INF/lib?  If so then I don't expect that
would work since Geronimo filters the jsf classes from a webapps
classloader.  This is a result of the JSF 1.2 specification 10.2.5
and 10.2.6 which says that webapps should not include the jsf classes
in their archive.  As we move forward I think it would be a great
idea to make the jsf implementation pluggable, but this will probably
be done by using Geronimo's plugin system instead of bundling the JSF
jars in a webapp's archive due to this language in the specification
and because of jsf implementation-specific functionality like
resource injection for managed beans.

The jsf support in Geronimo 2.0-M4 is more complete so I think you'll
have better luck with it.  However, that version has not been
officially released yet so you will need to build it from svn tag or
look in the dev@geronimo archive for the announcement of M4 release
candidate binaries.

Best wishes,
Paul


On Apr 23, 2007, at 7:52 AM, Arinté wrote:

> I am trying to run sun jsf impl 1.2 on Geronimo, but I keep running  into
> errors, is it even possible?  My current error is this:
> javax.servlet.ServletException:
> org/apache/commons/lang/builder/HashCodeBuilder
>         at javax.faces.webapp.FacesServlet.service (FacesServlet.java:152)
>         at
> org.apache.catalina.core.ApplicationFilterChain.internalDoFilter 
> (ApplicationFilterChain.java:290)
>         at
> org.apache.catalina.core.ApplicationFilterChain.doFilter 
> (ApplicationFilterChain.java:206)
>
> Even though I have commons lang in my geronimo.xml.  Also, when I  export
> this project to just plain tomcat 6 it works without me adding the 
> commons
> lang jar file anywhere, meaning I don't think sun uses it, but somehow
> myfaces is getting injected in here.
>
> Any tips or guides on getting this working?  I am using Geronimo 2 M3.
> Thanks
>
>
>





Mime
View raw message