geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Barrows" <jim.barr...@gmail.com>
Subject Re: Why am I getting NoClassDefFound for spring files in an EAR?
Date Wed, 25 Apr 2007 14:59:14 GMT
On 4/25/07, Prasad Kashyap <goyathlay.geronimo@gmail.com> wrote:
> Does your EAR have a simple application.xml ? I solved a similar
> problem by putting an application.xml

Yes it does.

And no matter where I put the filter classes, I get the same problem.
Or if I just get rid of all the plans, that doesn't help either.

It's getting really frustrating.

<geronimo:application
	xmlns:geronimo="http://geronimo.apache.org/xml/ns/j2ee/application-1.2"
	xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.2"
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xmlns:webapp="http://geronimo.apache.org/xml/ns/j2ee/web-1.2"
	xsi:schemaLocation="http://geronimo.apache.org/xml/ns/j2ee/application-1.2
http://geronimo.apache.org/xml/ns/j2ee/application-1.2
http://geronimo.apache.org/xml/ns/deployment-1.2
geronimo-module-1.2.xsd ">
	<sys:environment>
		<sys:moduleId>
			<sys:groupId>org.barrowsdevelopment</sys:groupId>
			<sys:artifactId>ese</sys:artifactId>
			<sys:version>1.0</sys:version>
			<sys:type>ear</sys:type>
		</sys:moduleId>
<!-- Filter classes don't work here -->
	</sys:environment>

	<geronimo:module>
		<geronimo:web>RM-UI-Web.war</geronimo:web>
		<webapp:web-app>
			<sys:environment>
				<sys:hidden-classes>
<!-- These don't work either -->
					<sys:filter>org.springframework</sys:filter>
					<sys:filter>antlr</sys:filter>
				</sys:hidden-classes>
			</sys:environment>
			<webapp:context-root>/rms</webapp:context-root>
		</webapp:web-app>

	</geronimo:module>

</geronimo:application>

>
> Cheers
> Prasad
>
> On 4/24/07, Jim Barrows <jim.barrows@gmail.com> wrote:
> > I found all of the web pages pointing out what to do when this happens
> > in a WAR, and my WAR works just fine.  However when I wrap my WAR in
> > an EAR, it doesn't work.
> > I've tried putting the hidden class filters in the
> > geronimo-application plan at both the EAR level and WAR level,  and
> > the geronimo-web plan.
> >
> > This wouldn't be so frustrating if it didn't work in the WAR stand
> > alone.. but it does.. and doesn't in the EAR.
> >
> > What do I need to do to make this work in an EAR?
> >
> > --
> > James A Barrows
> >
>


-- 
James A Barrows

Mime
View raw message