geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: A Geronimo complaint
Date Thu, 26 Apr 2007 07:37:25 GMT
You aren't really specifying enough context to know for sure what you  
are asking about.

If this is an excerpt from a geronimo plan, I suggest leaving out the  
version; geronimo will then choose the latest version in the geronimo  
repository at runtime.  From your request for a minimum version  
number I would think this would satisfy your requirements.
If this is an excerpt from a maven 2 pom then you should ask the  
maven team to make version ranges work more reliably.

Hope this is relevant to what you are asking about.

thanks
david jencks

On Apr 25, 2007, at 8:37 PM, Arinté wrote:

> If I have a Geronimo project that declares some  dependencies like  
> this:
>             <dependency>
>                 <groupId>org.apache.myfaces.core</groupId>
>                 <artifactId>myfaces-api</artifactId>
>                 <version>1.2.0-SNAPSHOT</version>
>                 <type>jar</type>
>             </dependency>
>
> When I move to another version of Geronimo I have to go through my  
> xml and
> redefine all these dependencies that sucks.  Maybe, the version number
> should represent a minimum and then that way migration up can be a lot
> easier.
>
> comments/questions?
>
>
>


Mime
View raw message