geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dkane <dka...@gmail.com>
Subject WASCE refuses to start
Date Wed, 11 Apr 2007 09:41:59 GMT

Dear colleagues,

I follow the instruction 
http://www-128.ibm.com/developerworks/websphere/library/techarticles/0604_sun/0604_sun.html

Using the Eclipse Plug-in for WebSphere Application Server Community Edition  
.

I have downloaded and installed WTP and WASCE 1.1 and added new server
runtime in
Eclipse IDE (3.2). My OS is Windows 2000. 

The first problem was that WASCE refused to start both from Program Files
menu and from Eclipse. The top of Exception stack trace was
"java.io.IOException: Cannot bind to URL [rmi://0.0.0.0:1099/JMXConnector"

I have replaced 0.0.0.0 to 127.0.0.1 in WASCE configuration file for
JMXConnector, and it solved the problem for standalone start.

Now server starts successfully from Program Files , but still does not start
from Eclipse. How it looks :

- I click "Start" in servers tab.
- Status changes to "Starting...", progress bar is moving.
- In "Console" tab , I finally see "Server started" and no exceptions.
- However, status remains "Starting..." and all that ends with message
dialog
"Community Edition 1.1 failed to start" after a minute or so.

I still suspect that server should start normally with default
configuration, i.e. 0.0.0.0 address for JMXConnector. I checked  ports 1099
and 9999 before starting Geronimo, they are not busy. I also tried to change
port values - no effect. 


Many thanks in advance. 
-- 
View this message in context: http://www.nabble.com/WASCE-refuses-to-start-tf3558281s134.html#a9936134
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message