geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jgunz <slo...@twcny.rr.com>
Subject Library conflict
Date Tue, 03 Apr 2007 12:31:21 GMT

I've been trying to build and deploy a GBean in a WAR file that contains a
set of third-party dependency libraries in WEB-INF/lib. One of these
libraries is XmlBeans 2.2.0. My application deploys fine but when it tries
to use XmlBeans I get a "no such method exception" which appears to be
caused by the use of an older version of XmlBeans. Geronimo uses 2.0.0 from
its repository and this seems to be the library that is used instead of the
bundled JAR.

Is there a solution to this problem that doesn't involve degrading to 2.0.0
and or using the common repository. I'd like to avoid the common repository
to simplify the deployment procedure.

I'm using geronimo-tomcat6-jee5-2.0-M3.

Thanks.
-- 
View this message in context: http://www.nabble.com/Library-conflict-tf3512229s134.html#a9809417
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message