geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hernan Cunico <hcun...@gmail.com>
Subject Re: Running portlets in Geronimo - Documentation
Date Thu, 05 Apr 2007 12:11:38 GMT
Yup, exactly. It wont let you install the server if you don't have the datasource defined first.
Maybe by having it this was it is somewhat easier, and maybe inviting, to customize the datasource.

Cheers!
Hernan

Paul McMahan wrote:
> On Apr 4, 2007, at 5:01 PM, Hernan Cunico wrote:
> 
>> A limitation of the data source creation wizard is that you cannot 
>> specify some of the values, more specifically all those that make the 
>> moduleId. Liferay plugin is specifically looking for a connection pool 
>> named *LiferayPool*  and with the following moduleId 
>> *liferay/liferay-pool/4.2.1/car*. If you use the console you'll get 
>> something like console.dbpool/LiferayPool/1.0/rar and installing the 
>> portal server plugin will fail.
>>
> 
> Hernan, you're exactly right.  I had forgotten about that limitation of 
> the data source wizard and how that the portal plugin relies on the 
> datasource plugin to use a certain module name.  The original reason I 
> put that dependency in place was to facilitate the relationship between 
> the plugins so that if you install portal plugin it will automatically 
> download and install the datasource plugin.  Or you could deploy a 
> customized datasource beforehand (like the mysql one you provided 
> instructions for) and the plugin installer wouldn't try to replace it 
> with the derby one.  The end goal was to minimize the number of steps it 
> takes new users to get a working portal server, while still allowing 
> more advanced users to use an external database like mysql or DB2.
> 
> At least that's how it used to work.  Now I believe the plugin catalog 
> lists the datasource plugin as a "prerequisite" of the portal plugin 
> instead of just a "dependency", so the plugin installer lists the portal 
> plugin as unavailable until you have installed the datasource plugin.  
> The Liferay team maintains the catalog so that may be how they prefer 
> things.  Or they might want to refine that part of their plugin catalog 
> when we look into updating it for Geronimo's upcoming 1.2 release.
> 
> Best wishes,
> Paul

Mime
View raw message