geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ibiddles <iv...@scientology.net>
Subject Re: Is Version 1.1.1(Released September 18, 2006) the stable version for development?
Date Wed, 21 Mar 2007 04:46:33 GMT

Dear Jacek,

The error I'm getting currently when I try to invoke the Deployment PLan
Editor has changed to:

Problems occurred when invoking code from plugin: "org.eclipse.jface".

java.lang.NoClassDefFoundError: org/eclipse/core/resources/IFile
   at org.apache.geronimo.st.ui.editors.SharedDeploymentPlanEditor.getLoader
(94)
   at
org.apache.geronimo.st.ui.editors.SharedDeploymentPlanEditor.loadDeploymentPlan
(86)
   at
org.apache.geronimo.st.ui.editors.AbstractGeronimoDeploymentPlanEditor.init
(18)
   at org.eclipse.ui.internal.EditorManager.createSite (842)

and the rest are all Eclipse entries. (I am having to type these in so I
don't want to go any further unless I have to).

I have checked my plugins and there is no reason I can see why
org/eclipse/core/resources/IFile should not be found and loaded.

Some other anomalies are that in the server overview, the only entry in the
runtime drop-down is Geronimo v1.1 and if I click on the Edit hyperlink next
to it nothing happens at all.

I will check out the WTP forums as you suggest.

Best wishes, Ivan.



Jacek Laskowski-4 wrote:
> 
> On 3/19/07, ibiddles <ivanb@scientology.net> wrote:
> 
>> You mention that the Eclipse plugin works with 2.0M3, Eclipse 3.3M5eh and
>> WTP 2.0M5. I have to run on 3.2.2 right now because of dependencies of
>> other
>> projects I am using.
> 
> That's the configuration I'm using so when asked replied with my
> experiences. Don't know about any other version(s).
> 
>> I have Eclipse 3.2.2, WTP1.5.3 and all of its specified dependencies (EMF
>> 3.2.2, GEF 3.2.2 and JEM 1.2.3).. I also have the latest unofficial daily
>> plugin (14-MAR). The problem is that I am getting an "Unhandled event
>> loop
>> exception" and then an NPE at
>> org.eclsipe.ui.internal.presentation.setFocus
>> (line 148) when I try to open the Geronimo deployment plan editor.
> 
> I've seen it reported on the Eclipse WTP forum. It can imply that it
> might not relate to the way the plugin works. When you open the
> deployment plan, are you sure you're using Geronimo-specific editor?
> Could you post the whole stack trace?
> 
>> Does the latest plugin build support my configuration or do I need to get
>> another plugin version from somewhere?
> 
> Don't know.
> 
> Jacek
> 
> -- 
> Jacek Laskowski
> http://www.JacekLaskowski.pl
> 
> 

-- 
View this message in context: http://www.nabble.com/Is-Version-1.1.1%28Released-September-18%2C-2006%29-the-stable-version-for-development--tf3407031s134.html#a9587290
Sent from the Apache Geronimo - Users mailing list archive at Nabble.com.


Mime
View raw message