geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Geronimo Eclipse Plugin publishes multiple times
Date Thu, 29 Mar 2007 14:57:48 GMT
The eclipse plugin doesn't use or redeploy using the hot deploy  
directory, and all its doing is exporting the archive out and  
deploying it as a jsr88 client of the server.  So why the server is  
attempting to restart 20-30 doesn't make sense to me, unless you some  
your are creating the eclipse projects inside the hot deploy  
directory or doing something to write out to it that is trigger some  
weird behavior.

The fact that other eclipse plugins (MyEclipse) is seeing a similar  
problem is strange and indicates to me a problem on the server side,  
but unless i have a test case that shows the behavior this is  
difficult to debug.

-sachin


On Mar 29, 2007, at 10:40 AM, Mark Aufdencamp wrote:

> I've seen similar behavior.
>
> I'm using the MyEclipse plug-in rather than the Geronimo plug-in.   
> I have a large webapp as a result of some embedded content (Bad  
> design but it's a prototype app).  It appears the auto deployer  
> polls the drive space to look for new applications and begins  
> deployment prior to the plug-in completing the copy.   On several  
> occasions the drive space as been out of sync with the repository  
> and I've had to manually delete the application directory to  
> correct the issue.  I've also resorted to building a .war and  
> manually deploying it, rather than relying on the plug-in to copy  
> the files.
>
> Perhaps the answer lies in tuning the polling interval on a per  
> installation basis.  Hope my two cents helps:)
>
>
> -------- Original Message --------
> Subject: Re: Geronimo Eclipse Plugin publishes multiple times
> From: "Johannes Weberhofer, Weberhofer GmbH" <office@weberhofer.at>
> Date: Thu, March 29, 2007 6:34 am
> To: user@geronimo.apache.org
>
> I can confirm this behaviour on our developers machines. As  
> geronimo 1.1.1 seem to "loose" around 5MB at every redeployment  
> (the PermGenSpace is growing), we usually can redeploy only 3-5  
> times before getting a PermGenSpace error: One EAR redeployment  
> causes 20-30 restarts of the application on the server, each time  
> loosing 5MB.
>
> We spent some time on investigating this issue, but as lack of  
> time, we started restarting geronimo frequently and/or redeploy on  
> exporting the ear file to the deploy directory, which does not show  
> this behaviour.
>
> I think, that Geronimo starts redeploying too early, already during  
> the redeployment.
>
> Btw: As the application is started very frequently, the server and  
> the redeploy process becomes very slow.
>
> Johannes Weberhofer
>
> Sachin Patel schrieb:
> > Ok.  Could you please open a JIRA and attach a test case that  
> reproduces
> > the problem? Please also indicate platform, and exact versions of
> > eclipse/wtp you are using.
> >
> > thx
> >
> > -sachin
> >
> >
> > On Mar 28, 2007, at 6:13 PM, Andres wrote:
> >
> >>
> >> We do not have autopublish enabled nor do we use XDoclet.  I do not
> >> have this
> >> problems with other servers (specifically Tomcat and Weblogic).
> >>
> >> Thanks,
> >>
> >> Andres
> >>
> >>
> >> Sachin Patel wrote:
> >>>
> >>> Do you have autopublish enabled and/or using XDoclet by chance? I
> >>> think someone else reported this behavior on other servers and I
> >>> think this may be a WTP bug but have yet to investigate  
> further.  If
> >>> you do have autopublish enabled, disable it and invoke manually
> >>> publishes.
> >>>
> >>> -sachin
> >>>
> >>>
> >>> On Mar 24, 2007, at 12:08 AM, Andres wrote:
> >>>
> >>>>
> >>>> Whenever I republish a WAR project using the Geronimo Eclipse
> >>>> plugin, it
> >>>> sometimes redeploys more than once.  I traced the eclipse plugin
> >>>> and I see
> >>>> it redeploying for every JAR that has changed, one at a time  
> (so if I
> >>>> rebuilt all 50 of my JAR projects, it results in 50 redeploys).
> >>>> I'm pretty
> >>>> sure this is related to an Eclipse bug that Sachin Patel opened
> >>>> (https://bugs.eclipse.org/bugs/show_bug.cgi?id=123676).  Does
> >>>> GERONIMODEVTOOLS-52 fix this problem in the 1.2.1 devtools branch
> >>>> by moving
> >>>> away from the generic server framework?  I tried building it  
> myself to
> >>>> verify but Maven could not download the artficat
> >>>> org.apache.geronimo.devtools:geronimo-1.1-emf:jar:1.0.
> >>>>
> >>>> Thanks,
> >>>>
> >>>> Andres Martinez
> >>>> --View this message in context: http://www.nabble.com/Geronimo-
> >>>> Eclipse-Plugin-publishes-multiple-times- 
> tf3457497s134.html#a9646873
> >>>> Sent from the Apache Geronimo - Users mailing list archive at
> >>>> Nabble.com.
> >>>>
> >>>
> >>>
> >>>
> >>
> >> --View this message in context:
> >> http://www.nabble.com/Geronimo-Eclipse-Plugin-publishes-multiple- 
> times-tf3457497s134.html#a9722275
> >>
> >> Sent from the Apache Geronimo - Users mailing list archive at  
> Nabble.com.
> >>
> >
>
> -- 
>
>
> |---------------------------------
> |  weberhofer GmbH               | Johannes Weberhofer
> |  information technologies
> |  Austria, 1080 Wien, Blindengasse 52/3
> |
> |  phone : +43 (0)1 5454421 0    | email: office@weberhofer.at
> |  fax   : +43 (0)1 5454421 19   | web  : http://weberhofer.at
> |  mobile: +43 (0)699 11998315
> |----------------------------------------------------------->>


Mime
View raw message