geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: Runing Apache Roller 3.0 on Geronimo 1.1.1
Date Sun, 25 Feb 2007 20:02:48 GMT
Jeff Genender and I spent some time trying to get approximately this  
version of roller working on approximately  that version of geronimo  
and ran into a bunch of serious problems, I think including the one  
you found.    I think the most serious problems are fixed in geronimo  
1.2 and 2.0 (neither released yet), but we haven't had time to try  
again.  In any case I recommend trying with one of these later  
geronimo versions.

It would be great to have a roller plugin.  Perhaps starting a JIRA  
and contributing the plans would provide a place to start and keep  
track of progress and problems?

thanks
david jencks

On Feb 25, 2007, at 11:24 AM, Peter Petersson wrote:

> Hi
>
> I am trying to run  Apache Roller <http://cwiki.apache.org/ 
> confluence/display/ROLLER> 3.0 on Geronimo 1.1.1 but soon after  
> startup (during the initial configuration steps) hibernate is  
> starting to throw
> org.hibernate.SessionException: Session is closed! exceptions (I am  
> not sure this is the course of the problems).
>
> Dose anyone have a tutorial or a working configuration to share  
> with the public available ?
> I have searched the web for it but have only come up with outdated  
> information.
> Any help in resolving the problems is greatly appreciated.
>
> Roller configuration changes:
> As I am using MySql 5.0.35 with (J/Connector 3.1.12) I have changed  
> the hibernate dialect accordingly
> hibernate.cfg.xml
>  :
> <!-- For MySQL 5.X, use the MySQL5 dialect and J/Connector 3.1.X  -->
> <property name="dialect">org.hibernate.dialect.MySQL5Dialect</ 
> property>
>  :
>
> Geronimo/Roller configuration
>
> Created the mysql roller database and deployed the db plan
> Database plan:
> <?xml version="1.0" encoding="UTF-8"?>
> <connector xmlns="http://geronimo.apache.org/xml/ns/j2ee/ 
> connector-1.1">
>   <dep:environment xmlns:dep="http://geronimo.apache.org/xml/ns/ 
> deployment-1.1">
>       <dep:moduleId>
>           <dep:groupId>console.dbpool</dep:groupId>
>           <dep:artifactId>MySqlDB_roller</dep:artifactId>
>           <dep:version>1.0</dep:version>
>           <dep:type>rar</dep:type>
>       </dep:moduleId>
>       <dep:dependencies>
>           <dep:dependency>
>               <dep:groupId>mysql</dep:groupId>
>               <dep:artifactId>mysql-connector-java</dep:artifactId>
>               <dep:version>3.1.12</dep:version>
>               <dep:type>jar</dep:type>
>           </dep:dependency>
>       </dep:dependencies>
>   </dep:environment>
>   <resourceadapter>
>       <outbound-resourceadapter>
>           <connection-definition>
>               <connectionfactory-interface>javax.sql.DataSource</ 
> connectionfactory-interface>
>               <connectiondefinition-instance>
>                   <name>MySqlDB_roller</name>
>                   <config-property-setting name="Password">thepw</ 
> config-property-setting>
>                   <config-property-setting  
> name="Driver">com.mysql.jdbc.Driver</config-property-setting>
>                   <config-property-setting name="UserName">thename</ 
> config-property-setting>
>                   <config-property-setting  
> name="ConnectionURL">jdbc:mysql://localhost:3306/roller</config- 
> property-setting>
>                   <connectionmanager>
>                       <local-transaction/>
>                       <single-pool>
>                           <max-size>10</max-size>
>                           <min-size>0</min-size>
>                           <match-one/>
>                       </single-pool>
>                   </connectionmanager>
>               </connectiondefinition-instance>
>           </connection-definition>
>       </outbound-resourceadapter>
>   </resourceadapter>
> </connector>
>
>
> geronimo-web.xml
>
> <?xml version="1.0" encoding="UTF-8"?>
> <web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1"  
> xmlns:nam="http://geronimo.apache.org/xml/ns/naming-1.1"  
> xmlns:sec="http://geronimo.apache.org/xml/ns/security-1.1"  
> xmlns:sys="http://geronimo.apache.org/xml/ns/deployment-1.1">
> <sys:environment>
>   <sys:moduleId>
>     <sys:groupId>m4u</sys:groupId>
>     <sys:artifactId>roller</sys:artifactId>
>     <sys:type>war</sys:type>
>   </sys:moduleId>
>     <sys:dependencies>
>     <sys:dependency>
>        <sys:groupId>console.dbpool</sys:groupId>
>        <sys:artifactId>MySqlDB_roller</sys:artifactId>
>     </sys:dependency>      </sys:dependencies>
> <!--    <hidden-classes>
>       <filter>antlr</filter>
>       <filter>org.springframework</filter>
>       <filter>org.apache.xerces</filter>
>       <filter>org.apache.commons.digester</filter>
>   </hidden-classes>
> -->                  </sys:environment>
>
> <context-root>/roller</context-root>
>   <sys:resource-ref>
>    <sys:ref-name>jdbc/rollerdb</sys:ref-name>
>    <sys:resource-link>MySqlDB_roller</sys:resource-link>
> </sys:resource-ref>
>
> </web-app>
>
> setenv.sh:
> JAVA_HOME=/usr/lib/jvm/java-1.5.0-sun
> JAVA_OPTS="-Djava.awt.headless=true -XX:MaxPermSize=128m -Xms128M - 
> Xmx512M -server"
>
> What am I missing or doing wrong here ? (or is there any known  
> issues running Roller on Geronimo)
>
> /Peter
>


Mime
View raw message