geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nirav Mehta" <>
Subject Re: ActiveMQ reference
Date Thu, 01 Feb 2007 12:57:00 GMT
Ok ... now I've created a new connection factory and a new queue. I changed
the web.xml to



Added the ref to geronimo deployment plan:
<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="" xmlns:nam="" xmlns:sec="" xmlns:sys="">


I still get the same error:
Unable to resolve resource reference 'jms/JMSTrialConFact' (Could not find
resource 'JMSTrialConFact'. Perhaps it has not yet been configured, or your
application does not have a dependency declared for that resource module?).


Nirav Mehta

On 1/31/07, Nirav Mehta <> wrote:
> Hi,
> I was trying out a JMS example from IBM DW. Here they used the server wide
> configs:
>     <resource-ref>
>         <res-ref-name>DefaultActiveMQConnectionFactory</res-ref-name>
>         <res-type> javax.jms.QueueConnectionFactory</res-type>
>         <res-auth>Container</res-auth>
>     </resource-ref>
> Trying to deploy the WAR gave:
> Unable to resolve resource reference 'DefaultActiveMQConnectionFactory'
> (Could not auto-map to resource. Try adding a resource-ref mapping to your
> Geronimo deployment plan.)
> I tried adding this is the geronimo deployment plan:
>   <nam:resource-ref>
>     <nam:ref-name>ra/ActiveMQ</nam:ref-name>
> <nam:resource-link>DefaultActiveMQConnectionFactory</nam:resource-link>
>   </nam:resource-ref>
> Still, I get the same error. Please help
> Regards,
> Nirav Mehta

View raw message