geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lin Sun <>
Subject Re: debugging WS deployed in Geronimo-2
Date Tue, 27 Feb 2007 14:35:54 GMT
Hi Kanchana, if you want to debug server side code and see the flow on 
the server side, you could follow this link about how to do remote 
debugging with jboss or weblogic:   I was able to 
follow that for geronimo 2.0 and add breakpoints on the server side to 
step through the code.


Kanchana Welagedara wrote:
> Hi Lin
> On Mon, 2007-02-26 at 10:09 -0500, Lin Sun wrote:
>> Hi there,
>> IIUC about what you are trying to do, you 'll need the WTP server 
>> adapter for geronimo 2.0 to do that.  But I don't think the adapter 
>> (also called devtools) is ready yet for 2.0.
> Yes.Exactly.But there should be a way around to do remotely debug a WS
> in Geronim using eclipse remote debugging isn't it?
> If I say what was trying to do exactly was..Tracing the flow of WS
> deployment through the geronimo code base and understand what method
> calls next and understand the code base.
>> I have only tried adding breakpoint on the server code and step through, 
>> instead of the client code.
> I think this is where I have made the mistake. I tried putting the break
> point  in client code first(now I know it should be server code) as well
> as in the server code later(The sample WS service server side along with
> geronimo code base).
> Then I tried to put the break point in geronimo code base in
> org.apache.geronimo.jaxws.builder.JaxwsServiceBuilder in parseWSDL,and
> it  complained "Unable to install breal points due to missing line
> number attributes.Also eclipse debugger doesn't launch or prompt to the
> debug mode to step on/over the flow.
> Hope I'm more specific now in details.
> Really appreciate if anybody can help out
> Regards
> Kanchana
>> HTH, Lin
>> Kanchana Welagedara wrote:
>>> Hi 
>>> I'm trying to debug a web service which deployed in the geronimo-2(with
>>> almost newest code built).
>>> Geronimo has started in the debugger mode(localhost port 8000) and the
>>> WS application has imported as an eclipse project on to eclipse along
>>> with the geronimo code base.
>>> When I put the break point on the client method and try to debug the
>>> flow of WS invocation,the eclipse debugger doesn't launch or prompt to
>>> the debug mode to step on/over the flow.
>>> am I missing any steps in process of debugging a WS deployed in geronimo
>>> using eclipse?
>>> Can anybody please help me on this
>>> Thanks and regards
>>> Kanchana

View raw message