A ha!!!  The "BUILDING.txt" file in the source distribution stated "To build me please install Maven from here - version 1.0.2 or later."  Maybe someone could update that document.  I'm gonna give M1 a try.  Thanks!

Daniel.

On 12/14/06, David Jencks <david_jencks@yahoo.com> wrote:

On Dec 13, 2006, at 9:39 AM, Daniel Bloomfield Ramagem wrote:

I downloaded the Geronimo 1.1.1 source code ZIP from the downloads page and I noticed that the Javadocs available on the main Apache Geronimo website don't match up to version 1.1.1 ( http://geronimo.apache.org/api/index.html), is this correct?

I am now trying to generate the Javadocs directly from the source code.  I added the following section to my c:\geronimo- 1.1.1_src\pom.xml file:

  <reporting>
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-javadoc-plugin</artifactId>
        <configuration>
          <aggregate>true</aggregate>
        </configuration>
      </plugin>
    </plugins>
  </reporting>

And then executed "mvn javadoc:javadoc" and also "mvn site" with no success in producing the Javadocs (output follows below).  What am I missing?

1.1.1 builds with maven1, not maven2.  You'll have to try modifying the project.xml and maven.xml files

thanks
david jencks


Daniel.