geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Petersson <pe...@pmb.mine.nu>
Subject Re: Issues Starting Geronimo
Date Thu, 14 Dec 2006 20:13:51 GMT
Hi

Im running Geronimo 1.1.1 on Ubuntu Linux.

Try using JDK insteed of JRE Geronimo is currently using the Sun ORB for 
RMI so it is required to use SUN JDK ( 
http://cwiki.apache.org/GMOxDOC11/quick-start-apache-geronimo-for-the-impatient.html 
)

If possible try starting geronimo standalone without any Apache 
(assuming it is apache) started seeing you get the following WARN 
[AJPHandler] Found AJP listener on port 8009
If you get it started try running it on localhost.

http://localhost:8080/console/
 
If not, before you start up geronimo check that noting else is using 
port 8080  run "netstat -penat" and check "Local Address" for something 
like ":::8080".

Cheers
   Peter

problems mail skrev:
> Aaron,
>  
> What do u see wrong in the startup. Here is the startup, also I have 
> not changed anything in the config.xml. Just download, extract and run 
> the command java -jar server.jar (was there something else I am 
> suppsed to be doing ?)
>
> Starting Geronimo Application Server v1.1.1
> [***********************] 100% 209s Startup complete
>   Listening on Ports:
>     1099 0.0.0.0 <http://0.0.0.0>   RMI Naming
>     1527 0.0.0.0 <http://0.0.0.0>   Derby Connector
>     4201 0.0.0.0 <http://0.0.0.0>   ActiveIO Connector EJB
>     4242 0.0.0.0 <http://0.0.0.0>   Remote Login Listener
>     8009 0.0.0.0 <http://0.0.0.0>   Tomcat Connector AJP
>     8080 0.0.0.0 <http://0.0.0.0>   Tomcat Connector HTTP
>     8443 0.0.0.0 <http://0.0.0.0>   Tomcat Connector HTTPS
>     9999 127.0.0.1 <http://127.0.0.1> JMX Remoting Connector
>    61616 0.0.0.0 <http://0.0.0.0>   ActiveMQ Message Broker Connector
>
>   Started Application Modules:
>     EAR: geronimo/webconsole-tomcat/1.1.1/car
>     RAR: geronimo/activemq/1.1.1/car
>     WAR: geronimo/remote-deploy-tomcat/1.1.1/car
>     WAR: geronimo/servlets-examples-tomcat/1.1.1/car
>     WAR: geronimo/welcome-tomcat/1.1.1/car
>
>   Web Applications:
>     http://rly.rmp.com:8080/
>     http://rly.rmp.com:8080/console
>     http://rly.rmp.com:8080/console-standard
>     http://rly.rmp.com:8080/remote-deploy
>     http://rly.rmp:8080/servlets-examples 
> <http://rly.rmp:8080/servlets-examples>
>
>  Regards,
> Simon
>
>
>  
> On 12/14/06, *problems mail* <problems.mail@gmail.com 
> <mailto:problems.mail@gmail.com>> wrote:
>
>     Aaron,
>      
>     Here is the reply for hostname
>      
>     [root@rly apacheserver]# hostname
>     rly.rmp.com <http://rly.rmp.com/>
>      
>      
>     [root@rly apacheserver]# more /etc/hosts
>     127.0.0.1 <http://127.0.0.1/>       localhost.localdomain localhost
>     192.128.1.110 <http://192.128.1.110/>   rly.rmp.com
>     <http://rly.rmp.com/>rly
>      
>     Regards,
>     Simon
>
>      
>     On 12/14/06, *Aaron Mulder* <ammulder@alumni.princeton.edu
>     <mailto:ammulder@alumni.princeton.edu>> wrote:
>
>         Most likely, there's still a problem with your /etc/hosts --
>         as in,
>         the machine's host name does not resolve to one of its actual IP
>         addresses.  Can you provide the output of "hostname" and the
>         contents
>         of your /etc/hosts file?
>
>         Thanks,
>              Aaron
>
>         On 12/14/06, problems mail < problems.mail@gmail.com
>         <mailto:problems.mail@gmail.com>> wrote:
>         > Hello,
>         >
>         > I have been able to successfully start Geronimo after having
>         issues with the
>         > /etc/hosts file.
>         >
>         > There are couple of issues or concerns wanted to verify, (is
>         1.1.1 the right
>         > version to download ??)
>         >
>         > => I still receive errors in the log file, are these ok ?
>         (attaching the log
>         > file)
>         > => It takes over 213s  (or approx. 4 minutes to start up),
>         and majority of
>         > the time it is waiting at this "Starting
>         geronimo/j2ee-security/1..." => I
>         > cannot even shutdown the server it displays an error or stack
>         dump when I do
>         > a "Ctrl + C" on the shell window running the apache geronimo
>         process.
>         > => I tried to call the shutdown.jar, it is not able to
>         connect and shutdown
>         > the Geronimo server
>         >
>         > Is there any setting that we need to do in the IPTables ?
>         >
>         > Are most of the users running Geronimo on Windows ? (looks
>         like they dont
>         > seem to have any issues ??)
>         >
>         > Any help greatly appreciated.
>         >
>         > --
>         > Regards,
>         > Simon
>         >
>
>
>
>
>     -- 
>     Regards,
>     Simon 
>
>
>
>
> -- 
> Regards,
> Simon 


Mime
View raw message