geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rick McGuire <rick...@gmail.com>
Subject Re: sending email in geronimo
Date Thu, 07 Dec 2006 09:48:06 GMT
You must be using Geronimo 1.0.  The newer 1.1 version has a more fully 
implemented version of javamail 1.3.1 level.  Upgrading to 1.1 should 
fix your problem unless you are dependent upon new features in the 1.4 
version. 

Unfortunately, because the javamail api code is used by other server 
services such as axis, the Geronimo resident version gets picked up 
first in the classloading sequence over your WEB_INF/lib directory.  I 
believe there might be some means to override that, but I've never done 
this myself, so I'm not sure how it would be done.  One simple way to 
override this is to drop the Sun javamail 1.4 jars into the ext directory.

Rick

Melvin Dave Vivas wrote:
> Hi,
>
> I have a problem with sending email using javamail 1.4 in Geronimo.
> Here is the error I am getting.
>
> java.lang.UnsupportedOperationException: Method not yet implemented
>        at 
> javax.mail.internet.MimeMessage.addRecipients(MimeMessage.java:287)
>
> I suspect that there is a classloading problem with my jars. Any ideas
> on what workaround I can implement?
>
> By the way, can we force the application to load classes first from
> the web application's WEB-INF/lib directory? This is where I place my
> javamail libraries.
>
> Thanks!
>
> Melvin
>


Mime
View raw message