geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Moser" <...@zurich.ibm.com>
Subject Re: JavaScript error on Geronimo's console when requesting "Information"
Date Mon, 13 Nov 2006 10:15:35 GMT
Yes - 1939 sounds very similar - at least the same error messages and 
location.

The JIRAs offer no solution, though, but only guess at possible reasons 
and ask for a solution other than requiring the Adobe SVG plugin. I 
testet my SVG plugin as described in the first JIRA and it seems to 
work - at least according to the Adobe test page, so at least that does 
not seem to be the problem here...

I didn't find any option in IE7 to fiddle with JS caching. I found 
another, though, that "disables script debugging". After unchecking that 
one (i.e. enabling "script debugging"), I now - after clicking away the 
first alert - get a second one on that page that reads:
------------------
'navigator.userAgent' is null or not an object
line: 416, column: 0
------------------

I did a quick search myself, but none of the java-scripts mentioned in 
my previous append, is that long. The only source that's long enough is 
the main info page itself, but it has some plain vanilla HTML code (some 
table) at that location, so no indication what could be wrong here, 
either.

Maybe that error message rings some bell or provides a clue to someone 
else?

Michael


"Paul McMahan" <paulmcmahan@gmail.com> 
wrote in message 
news:21df75940611100954i4c49fd9mc4750a5b1463a13f@mail.gmail.com...
> Thanks for doing the extra detective work. This looks like a problem
> in IE7 javascript processing to me.  The offending script you
> referenced is only present in the login page and is inlined directly
> in that JSP's html content.  It is not (or at least I don't understand
> how it could possibly be) in any of the JS files that are included
> when you view the Information portlet.  My suspicion is that if you
> view those same JS files using firefox then you won't see the same
> contents as in IE,  which indicates to me that IE7 is not caching JS
> files correctly.  Disabling caching in your browser may provide some
> further clues.
>
> I believe the root of this problem is related to the issue described
> in this JIRA:
> http://issues.apache.org/jira/browse/GERONIMO-1939
> Which will probably be addressed by this JIRA:
> http://issues.apache.org/jira/browse/GERONIMO-2552
>
> Best wishes,
> Paul
>
>
> On 11/10/06, Michael Moser 
> <mmo@zurich.ibm.com> wrote:
>> In the main document there is only plain vanilla HTML code at that 
>> line
>> ------------
>>        ...
>>       <tr><td><div class="Selection"><table width="100%" border="0"
>> cellpadding="1" cellspacing="0">
>>        ...
>> ------------
>> so I guess, that's not the culprit.
>>
>> The page references four other .js files:
>>
>> One in the header:
>> <script language="Javascript" src="/console/js/forms.js"
>> type="text/javascript"></script>
>> That file is only 33 lines long, so no suspicious line 82, either.
>>
>> And three more in the body (starting at line 658):
>> <script type='text/javascript'
>> src='/console/portal/../dwr/interface/Jsr77Stats.js'></script>
>> <script type='text/javascript'
>> src='/console/portal/../dwr/engine.js'></script>
>> <script type='text/javascript'
>> src='/console/portal/../dwr/util.js'></script>
>>
>> In all three of these (generated from the same style-sheet or code?)
>> line 82 reads ('>>' added by me to mark line 82):
>> ------------
>>        ...
>>                    <script>
>> >>                 if (document.cookie == "") {
>>                      document.writeln('<font 
>> color="red"><strong>Note:
>> Logging onto the Geronimo Console requires cookies to be enabled in 
>> your
>> web browser.</strong></font><br>');
>>                    }
>>                    </script>
>>        ...
>> ------------
>> Beats me why IE7 doesn't like that. I don't see anything fishy here -
>> maybe you ?
>>
>> Michael
>>
>>
>>
>> "Aaron Mulder"
>> <ammulder@alumni.princeton.edu> wrote in
>> message
>> news:74e15baa0611100740w186653dfrf255c92f10d862d2@mail.gmail.com...
>> > Can you find out what's at line 82?
>> >
>> > Thanks,
>> >       Aaron
>> >
>> > On 11/10/06, Michael Moser
>> > <mmo@zurich.ibm.com> wrote:
>> >> Downloaded and installed geronimo 1.1.1 to WinXP box.
>> >> Start & login as system/manager and click on the "Information" 
>> >> link
>> >> on
>> >> left side tree-view.
>> >>
>> >> I always get a JavaScript error reading:
>> >> "Wrong number of parameters, 1 expected
>> >> line 82, column: 0"
>> >>
>> >> Yes, I admit, this is using Internet Explorer (V7) - with Firefox
>> >> there
>> >> is no such error...
>> >>
>> >> Michael
>> >>
>> >>
>> >>
>> >
>>
>>
>>
> 



Mime
View raw message