geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Re: Clustering and Database Access
Date Wed, 08 Nov 2006 15:53:41 GMT
Can you post your geronimo-web.xml?  It sounds like maybe some
elements are out of order or have the wrong namespace.  Or, if you
have an XML Schema validation tool or function in your IDE you might
try validating your geronimo-web.xml against the geronimo-tomcat
schema in the schemas/ directory of your Geronimo tree.

Thanks,
      Aaron

On 11/8/06, Chris Hall <crh@trifecta.com> wrote:
> Hello,
>
> I've been playing with a Geronimo cluster recently and it's gone rather
> well thus far.  Load balancing, session replication, and sticky sessions
> are all working... but database access has me stumped.
>
> I'm running into the following error when I attempt to deploy to the
> cluster:
>
> xml problem for web app .
> ...<snipped>...
> Caused by: org.apache.xmlbeans.XmlException: Invalid deployment
> descriptor: [error: cvc-complex-type.2.4a: Expected elements
> 'resource-ref@http://geronimo.apache.org/xml/ns/naming-1.1
> resource-env-ref@http://geronimo.apache.org/xml/ns/naming-1.1
> message-destination@http://geronimo.apache.org/xml/ns/naming-1.1
> security-realm-name@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-1.1
> gbean@http://geronimo.apache.org/xml/ns/deployment-1.1' instead of
> 'cluster@http://geronimo.apache.org/xml/ns/j2ee/web/tomcat-1.1' here]
>
>
> The WAR works correctly on this server when the clustering GBeans aren't
> included in the deployment plan, so I know the application and the
> database pool are correct.  The Geronimo sample applications deploy
> correctly to the cluster and I can see session replication and sticky
> sessions in action, so I know that the cluster is configured correctly.
>
> The problem is in my deployment plan, and the error message confirms
> this.  However, it's virtually identical to the plan used by the sample
> applications (which work on the cluster).  The only difference is the
> inclusion of a <resource-ref/> element to map the DB pool to a JNDI
> resource (the same element that works without clustering).  Pulling the
> <resource-ref/> element out of the deployment plan and the web.xml
> allows the application to deploy... though without DB access.
>
> Has anyone configured a cluster with database access?  Am I going about
> this in the right way, or am I completely off-base?
>
> I can provide the geronimo-web.xml and web.xml if they will help.
>
> Thanks.
>
>
> -Chris
>

Mime
View raw message