geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lasantha Ranaweera <lasan...@opensource.lk>
Subject Re: Error deploying EAR because of DataSource
Date Fri, 27 Oct 2006 08:44:25 GMT
What is the DB you are using? Is it Derby Embedded?

Thanks,
Lasantha Ranaweera

Guillaume Bilodeau wrote:
> Hi David,
>
> Not sure if that's what you mean, but I deployed the datasource myself using
> the "Geronimo database pool wizard", not through a separate deployment plan. 
> Is that it?
>
> Thanks,
> GB
>
>
> David Jencks wrote:
>   
>> Everything you show looks ok to me, which makes me wonder if the  
>> console-generated rar plan really has the connection factory named  
>> AuchanPromoDS.  Could you show the plan for deploying the datasource?
>>
>> thanks
>> david jencks
>>
>> On Oct 26, 2006, at 11:03 PM, Guillaume Bilodeau wrote:
>>
>>     
>>> Ok let's try this again, without altering any names :)  I'm using
>>> Geronimo+Tomcat 1.1.1 on Java 5.
>>>
>>> Error:
>>>  	
>>> Deployment failed:
>>> Unable to resolve resource reference 'jdbc/AuchanPromoDS' (Could  
>>> not find
>>> resource 'AuchanPromoDS'. Perhaps it has not yet been configured,  
>>> or your
>>> application does not have a dependency declared for that resource  
>>> module?)
>>>
>>> "Installed J2EE connectors" screen:
>>> console.dbpool/AuchanPromoDS/1.0/rar  	 running  	  Stop   	   
>>> Restart   	
>>> Uninstall
>>>
>>> web.xml:
>>>
>>> <?xml version="1.0" encoding="UTF-8" ?>
>>>
>>> <web-app xmlns="http://java.sun.com/xml/ns/j2ee"
>>> 	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>>> 	xsi:schemaLocation="http://java.sun.com/xml/ns/j2ee
>>> http://java.sun.com/xml/ns/j2ee/web-app_2_4.xsd"
>>> 	version="2.4">
>>> ...
>>>     <resource-ref>
>>>         <res-ref-name>jdbc/AuchanPromoDS</res-ref-name>
>>>         <res-type>javax.sql.DataSource</res-type>
>>>         <res-auth>Container</res-auth>
>>>         <res-sharing-scope>Shareable</res-sharing-scope>
>>>     </resource-ref>
>>> ...
>>> </web-app>
>>>
>>> geronimo-web.xml:
>>>
>>> <?xml version="1.0" encoding="UTF-8"?>
>>>
>>> <web-app xmlns="http://geronimo.apache.org/xml/ns/web">
>>> 	<environment>
>>> 		<moduleId>
>>> 			<artifactId>promo-war</artifactId>
>>> 		</moduleId>
>>> 		<dependencies>
>>> 			<dependency>
>>> 				<groupId>console.dbpool</groupId>
>>> 				<artifactId>AuchanPromoDS</artifactId>
>>> 			</dependency>
>>> 		</dependencies>
>>> 	</environment>
>>>
>>> 	<context-root>/auchan-promo</context-root>
>>>
>>> 	<resource-ref>
>>> 		<ref-name>jdbc/AuchanPromoDS</ref-name>
>>> 		<resource-link>AuchanPromoDS</resource-link>
>>> 	</resource-ref>
>>> </web-app>
>>>
>>> applicationContext.xml:
>>>
>>> 	<jee:jndi-lookup id="mainDataSource"
>>> 		jndi-name="java:comp/env/jdbc/AuchanPromoDS"
>>> 		proxy-interface="javax.sql.DataSource"
>>> 		lookup-on-startup="false" />
>>>
>>> application.xml:
>>>
>>> <?xml version="1.0" encoding="UTF-8"?>
>>> <!DOCTYPE application PUBLIC
>>> 	"-//Sun Microsystems, Inc.//DTD J2EE Application 1.3//EN"
>>> 	"http://java.sun.com/dtd/application_1_3.dtd">
>>> <application>
>>>   <display-name>promo-ear</display-name>
>>>   <description>Promo Action Management System EAR</description>
>>>   <module>
>>>     <web>
>>>       <web-uri>promo-web-2.0.0-SNAPSHOT.war</web-uri>
>>>       <context-root>/auchan-promo</context-root>
>>>     </web>
>>>   </module>
>>>   <module>
>>>     <ejb>promo-server-2.0.0-SNAPSHOT.jar</ejb>
>>>   </module>
>>> </application>
>>>
>>> It seems to me that I followed what the usage screen suggests.  Is  
>>> this a
>>> problem with dealing with EARs?
>>>
>>> Thanks,
>>> GB
>>>
>>>
>>> On 10/26/06, Guillaume Bilodeau <gbilodeau@yahoo.com> wrote:
>>>       
>>>> Yes actually that was a mistake in my post, I forgot to remove all
>>>> references
>>>> to my current client :)  All names are correct in my code, all of  
>>>> them
>>>> being
>>>> jdbc/<insertClientNameHere>PromoDS.
>>>>
>>>> Any other idea?
>>>>         
>>> Can you look in the database pool screen in the console, and select
>>> the usage link next to your database pool, and make sure that all the
>>> names in the example there match the ones in your geronimo-web.xml
>>> file?  It's hard to troubleshoot from the config files if you're
>>> changing the important entries as you post them.  :)
>>>
>>> Also, are you using Geronimo 1.0 or Geronimo 1.1?  The XML namespaces
>>> in the geronimo-web.xml file aren't really correct for Geronimo 1.1,
>>> though it may auto-convert them.  I'd try putting in the proper values
>>> (which you can get from here http://geronimo.apache.org/schemas.html).
>>>
>>> Thanks,
>>>       Aaron
>>>
>>> -- 
>>> View this message in context: http://www.nabble.com/Error-deploying- 
>>> EAR-because-of-DataSource-tf2513035.html#a7024975
>>> Sent from the Apache Geronimo - Users mailing list archive at  
>>> Nabble.com.
>>>
>>>       
>>
>>     
>
>   


Mime
View raw message