geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "mahu2425" <mahu2...@lycos.de>
Subject Re: Can not deploy EAR in Geronimo 1.1.1
Date Thu, 01 Jan 1970 00:00:00 GMT
Hi Aaron,
strange, I send the email just once to the mailing list ?!?!  ;-)

I expose the EJB as a web service, that means the jar archive for the
enterprise bean additionally includes a webservices.xml file, a WSDL file
and a JAX-RPC mapping file. Everything worked fine on Geronimo 1.0.
I tried to change the openejb-jar.xml as you described and the application
has been successfully deployed.

So, might this be a bug or a new feature? In the second case I would prefer
the behaviour from version 1.0.  ;-)

Maybe you also have an idea why there is again a problem creating a sql
security realm in 1.1.1. I created a (solved) jira bug for a different sql
security realm problem in version 1.1.0. If you are interested and find
some time have a look at my other posting.

Thanks and best regards,

Markus


> By "preferably once" I mean that I got four copies of your first
> message and two copies of your second.  :)
> 
> The plan below looks pretty simple.  The error was related to web
> services, and I don't see anything there related to web services -- do
> you expose that EJB as a web service or does it have a web service
> reference that it uses?
> 
> In any case, you might be able to solve the problem by changing this line:
> 
> <sys:dependencies />
> 
> to something more like this:
> 
> <sys:dependencies>
>   <sys:dependency>
>     <sys:groupId>geronimo</sys:groupId>
>     <sys:artifactId>jetty</sys:artifactId>
>     <sys:type>car</sys:type>
>   </sys:dependency>
> </sys:dependencies>
> 
> That is, it seems like the EJB web services features are looking for
> Jetty and not finding it, so we'll try telling the app that it has an
> explicit dependency on the Jetty module.
> 
> Thanks,
>      Aaron

Schnell und einfach ohne Anschlusswechsel zur Lycos DSL Flatrate wechseln und 3 Monate kostenlos
ab effektiven 5,21 EUR pro Monat im ersten Jahr surfen.
http://www.lycos.de/startseite/online/dsl/index.html?prod=DSL&trackingID=email_footertxt
Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message