geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Uwe Muench" <umue...@hs-furtwangen.de>
Subject AW: geronimo-web.xml for openlaszlo
Date Sat, 07 Oct 2006 16:16:43 GMT
--> The application was successfully deployed.
--> The application was successfully started

But still SSL isn´t right!!! Nothing happen!

Any solution für this?

<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
  <dep:environment
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
   <dep:moduleId>
     <dep:groupId>openlaszlo</dep:groupId>
     <dep:artifactId>openlaszlo</dep:artifactId>
     <dep:version>3.3.3.0</dep:version>
     <dep:type>car</dep:type>
   </dep:moduleId>
   <dep:dependencies/>
   <dep:hidden-classes>
	   <filter>org.jdom</filter>
	   <filter>org.apache.axis</filter>
	   <filter>org.apache.commons.logging</filter>
	   <filter>org.apache.log4j</filter>
   </dep:hidden-classes>
   <dep:non-overridable-classes/>
 </dep:environment>
  <context-root>/openlaszlo</context-root>
</web-app>

-----Ursprüngliche Nachricht-----
Von: Paul McMahan [mailto:paulmcmahan@gmail.com] 
Gesendet: Samstag, 7. Oktober 2006 18:00
An: user@geronimo.apache.org
Betreff: Re: geronimo-web.xml for openlaszlo

Aaron's advice is right on the money (as usual).  Applying his
recommendation to your plan I created the following deployment plan
which worked fine for me in geronimo 1.1.1:

<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
  <dep:environment
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.1">
   <dep:moduleId>
     <dep:groupId>openlaszlo</dep:groupId>
     <dep:artifactId>openlaszlo</dep:artifactId>
     <dep:version>3.3.0</dep:version>
     <dep:type>war</dep:type>
   </dep:moduleId>
   <dep:dependencies/>
   <dep:hidden-classes>
	   <filter>org.jdom</filter>
	   <filter>org.apache.axis</filter>
   </dep:hidden-classes>
   <dep:non-overridable-classes/>
 </dep:environment>
  <context-root>/openlaszlo</context-root>
</web-app>

By the way, after deploying in geronimo with this plan I still saw
some strange behavior from the stuff in lps/admin that looked related
to xml parsing errors.  It may be that additional class filters are
needed?  If you see the same results and make progress on solving that
issue then would you mind sharing your results with us?  I think
openlaszlo is a great technology and would even make an excellent
geronimo plugin.

Best wishes,
Paul

On 10/7/06, Aaron Mulder <ammulder@alumni.princeton.edu> wrote:
> One way to go would be to remove the entire <dep:environment> block,
> and move the <hidden-classes> elements inside the <environment> block
> and combine the two into one <hidden-classes> with two <filter>
> children...  Something like:
>
> <web-app ...>
>   <environment>
>      <moduleId ...
>      <hidden-classes>
>         <filter ...
>         <filter ...
>      </hidden-classes>
>   </environment>
>   <context-root ...
> </web-app>
>
> Thanks,
>       Aaron
>


Mime
View raw message