geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron Mulder" <ammul...@alumni.princeton.edu>
Subject Re: Config problem with QuartzScheduler
Date Wed, 27 Sep 2006 11:28:18 GMT
There was a bug fixed in Geronimo 1.1.1 that definitely seems related
-- but I wasn't aware that it struck if you just ran the server with a
plugin like that.  Anyway, is it an option for you to upgrade to
1.1.1?

Thanks,
      Aaron

On 9/27/06, Peter Petersson <peter@pmb.mine.nu> wrote:
> Hi all!
>
> I use Geronimo 1.1 and have installed the QuartzScheduler and
> QuartzDeployer pluggins and it works fine until i restart the server.
> The Geronimo server fails to start due to a configuration error for
> QuartzScheduler in ${GERONIMO_HOME}/var/config/config.xml
> I have found the problem to be the marked line below
>
> <module load="false" name="gplugins/quartz-scheduler/0.2/car">
> <gbean name="QuartzScheduler">
> <attribute name="quartzProperties">org.quartz.threadPool.class=org.gplugins.quartz.QuartzThreadPool
>    org.quartz.scheduler.jobFactory.class=org.gplugins.quartz.QuartzJobFactory</attribute>
> <reference name="ThreadPool">
> <pattern/> <<<<<<<<<<<<<<<<==========================
> </reference>
> </gbean>
> </module>
>
> When I "correct" it and starts the server with
>
> <module name="gplugins/quartz-scheduler/0.2/car">
> <gbean name="QuartzScheduler">
> <attribute name="quartzProperties">org.quartz.threadPool.class=org.gplugins.quartz.QuartzThreadPool
>    org.quartz.scheduler.jobFactory.class=org.gplugins.quartz.QuartzJobFactory</attribute>
> <reference name="ThreadPool">
>         <pattern>
>           <name>DefaultThreadPool</name>
>         </pattern>
> </reference>
> </gbean>
> </module>
>
> It works fine until the next time I stop and start the server as the
> config.xml file is regenerated with the error.
>
> What can I do to fix the problem (permanently)?
>
> Cheers
>    Peter
>

Mime
View raw message