geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From raxpl <ra...@ANGLESEY.GOV.UK>
Subject Re: Problem Deploying Exploded Webapp Directory
Date Fri, 01 Sep 2006 13:34:04 GMT

it's taking far too long...the server's either doing lot of other things for
you or their something up...have you looked at the logs for startup
errors...mines got some (mainly transaction related) but the hot deployment
works fine - but my jsp apps. are very little, you might be deploying
something pretty big ?


Cobb, Kevin L Mr CONT USAAC wrote:
> 
> I am brand new to Geronimo, but not new to Application Servers or Web
> Development. Been using Tomcat and others for a long time. 
> 
> I am trying to use Geronimo as my Development App Server, so naturally,
> I would like to be able to "hot deploy". Documentation on that subject
> is pretty thin. Initial Deployment works as expected, I copy over the
> Web App directory to the GERONIMO HOME/deploy directory, with the
> necessary files including geronimo-web.xml and web.xml, and the site
> comes up fine. But, when I change a JSP file and copy it over to the
> existing deploy directory, I get an error (see below). Any hints or
> suggestions for doing "hot deploys"?
> 
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 
> 12:04:54,570 ERROR [Hot Deployer] Unable to undeploy
> D:\Servers\geronimo-1.1\deploy\MY_APP(myapp/MY_APP/1.1/war)Module
> myapp/MY_APP/1.1/war already exists in the server.  Try to undeploy it
> first or use
> the redeploy command.
> org.apache.geronimo.common.DeploymentException: Module
> myapp/MY_APP/1.1/war already exists in the server.  Try to undeploy it
> first or use the redeploy command.
>         at
> org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:254)
>         at
> org.apache.geronimo.deployment.Deployer.deploy(Deployer.java:124)
>         at
> org.apache.geronimo.deployment.Deployer$$FastClassByCGLIB$$734a235d.invo
> ke(<generated>)
>         at net.sf.cglib.reflect.FastMethod.invoke(FastMethod.java:53)
>         at
> org.apache.geronimo.gbean.runtime.FastMethodInvoker.invoke(FastMethodInv
> oker.java:38)
>         at
> org.apache.geronimo.gbean.runtime.GBeanOperation.invoke(GBeanOperation.j
> ava:122)
>         at
> org.apache.geronimo.gbean.runtime.GBeanInstance.invoke(GBeanInstance.jav
> a:852)
>         at
> org.apache.geronimo.kernel.basic.BasicKernel.invoke(BasicKernel.java:239
> )
>         at
> org.apache.geronimo.deployment.plugin.local.AbstractDeployCommand.doDepl
> oy(AbstractDeployCommand.java:106)
>         at
> org.apache.geronimo.deployment.plugin.local.RedeployCommand.redeployUpda
> tedConfiguration(RedeployCommand.java:135)
>         at
> org.apache.geronimo.deployment.plugin.local.RedeployCommand.run(Redeploy
> Command.java:104)
>         at java.lang.Thread.run(Thread.java:595)
> 
> Thanks,
> 
> Kevin
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-Deploying-Exploded-Webapp-Directory-tf2197766.html#a6098679
Sent from the Apache Geronimo - Users forum at Nabble.com.


Mime
View raw message