On Aug 6, 2006, at 11:13 PM, Lin Sun wrote:

Thanks for the reply.  Were you updating from Eclipse 3.1.2, WTP 1.0.1 with
AG 1.0 plugins?  Or were you updating from Eclipse 3.2, WTP 1.5 with AG 1.0
plugins?

I was updating from 3.2/1.5/G1.0 to 3.2/1.5/G1.1 but it shouldn't matter, each of them updates independently.


I am using the first scenario. From the progress info, it seems only
updating to WTP 1.0 maitenance level (for example 1.0.3).

Did you make sure you're pointing to the new Callisto site? See the Eclipse home page for more information.


I'll read me on eclipse doc to see if it is possible to update WTP 1.0.1 to
WTP 1.5 from update manager. but if you have any insight info let me know.

Yes this is possible.  Like mentioned above my guess is that you're not pointing to the correct update site.


Thanks!  Lin

________________________________________
From: Sachin Patel [mailto:sppatel@gmail.com] On Behalf Of Sachin Patel
Sent: Friday, August 04, 2006 5:20 PM
To: user@geronimo.apache.org
Subject: Re: migrate from 1.0 eclipse plugin to 1.1 eclipse plugin

It should and does work, I've tested the scenario before releasing the
plugin. It may not work via the product configuration panel since I think
theres some items missing in the feature manifest but should definitely work
if you go directly to the update manager.

On Aug 4, 2006, at 4:18 PM, Lin Sun wrote:


Hi there,

Has anyone tried to migrate from 1.0 eclipse plugin to 1.1 eclipse plugin
using the update manager?

I tried to issue a scan for update of org.apache.geronimo.feature 1.0.0 in
the product configuration panel (in Eclipse) but it didn't return any update
of the feature.

I didn't quite understand this, as in the site.xml, we have:

<feature url="features/org.apache.geronimo.feature_1.0.0.jar"
id="org.apache.geronimo.feature" version="1.0.0">
<category name="Geronimo Server Adapter"/>
</feature>

<feature url="features/org.apache.geronimo.feature_1.1.0.jar"
id="org.apache.geronimo.feature" version="1.1.0">
<category name="Geronimo Server Adapter"/>
</feature>

I had hoped that above would make the update manager to recognize that there
is a newer version of the feature, but apparently it doesn't.

Thoughts?

Lin



-sachin






-sachin