geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From raxpl <ra...@ANGLESEY.GOV.UK>
Subject virtual host problem
Date Sat, 26 Aug 2006 20:57:56 GMT

hi list
geronimo-1.1 on java jdk 5 on debian sarge (stable)
setting up virtual hosting seemed to go ok until shutting down & restarting
geronimo - then virtual host disappeared =

HTTP Status 404 - No application present at the context root
type Status report
message No application present at the context root
description The requested resource (No application present at the context
root) is not available.

I've fiddled with it a for a few hours, nothing doing...including rebuilding
the war...

geronimo-web.xml is:
<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-1.1">
  <environment>
    <moduleId>
      <groupId>sample.applications</groupId>
      <artifactId>app1</artifactId>
      <version>1.1</version>
    </moduleId>
  </environment>
  <context-root></context-root>
  <host>mynetwork.net</host>
</web-app>

mynetwork.net is set by dns (the server is hosted, I get to it by ssh or
thru the console) and there's a very simple jsp in the war (a la the
tutorial for the impatient)

did anybody else find virtual hosting a breeze ?

rich




-- 
View this message in context: http://www.nabble.com/virtual-host-problem-tf2170496.html#a6001474
Sent from the Apache Geronimo - Users forum at Nabble.com.


Mime
View raw message