geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun" <linsun....@gmail.com>
Subject RE: migrate from 1.0 eclipse plugin to 1.1 eclipse plugin
Date Mon, 07 Aug 2006 19:31:00 GMT
Ok I've figured out the gotchas.  First of all, my environment needs to be
at WTP 1.5 and Eclipse 3.2 level (due to bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=153004).  Second, instead of
selecting the radio box next to "search for updates of the currently
installed feature", I had to select the radio box next to "search for new
features to install".   This will bring down the 1.1 eclipse plugin (WTP
server adapter for AG 1.1) as a new feature.

If I selected "search for updates of the currently installed feature", I
would get "no updates".   It might be good to have this documented as it
isn't obvious.

lin

________________________________________
From: Sachin Patel [mailto:sppatel@gmail.com] On Behalf Of Sachin Patel
Sent: Friday, August 04, 2006 5:20 PM
To: user@geronimo.apache.org
Subject: Re: migrate from 1.0 eclipse plugin to 1.1 eclipse plugin

It should and does work, I've tested the scenario before releasing the
plugin. It may not work via the product configuration panel since I think
theres some items missing in the feature manifest but should definitely work
if you go directly to the update manager.

On Aug 4, 2006, at 4:18 PM, Lin Sun wrote:


Hi there,

Has anyone tried to migrate from 1.0 eclipse plugin to 1.1 eclipse plugin
using the update manager?

I tried to issue a scan for update of org.apache.geronimo.feature 1.0.0 in
the product configuration panel (in Eclipse) but it didn't return any update
of the feature.

I didn't quite understand this, as in the site.xml, we have:

<feature url="features/org.apache.geronimo.feature_1.0.0.jar"
id="org.apache.geronimo.feature" version="1.0.0">
<category name="Geronimo Server Adapter"/>
</feature>

<feature url="features/org.apache.geronimo.feature_1.1.0.jar"
id="org.apache.geronimo.feature" version="1.1.0">
<category name="Geronimo Server Adapter"/>
</feature>

I had hoped that above would make the update manager to recognize that there
is a newer version of the feature, but apparently it doesn't.

Thoughts?

Lin



-sachin





Mime
View raw message