geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From john.enevold...@pulsen.se
Subject stress test performance issue
Date Fri, 14 Jul 2006 10:11:23 GMT

Hi,

We are doing some simple stress testing running ca 1500 requests
(identical) over
a 60 second period repeatedly. Most of the time we see everything running
smoothly
but for a 1 or 2 second interval in most of the tests we see throughput
dropping to zero.

vmstat typicall shows

  r  b   swpd   free    buff      cache   si   so    bi  bo   in    cs
us  sy   id   wa

 0  0  17444   3624  20060 100968    0    0     0    68  107   369      6
0    94  0
 0  0  17456   4244  19280 100188    0    0     0    12  103   348      5
2    93  0
 2  0  17456   3872  19280 100188    0    0     0     0   102   222    50
0    50  0
 0  0  17456   3748  19280 100188    0    0     0    24  106 34792 34  16
50  0
 0  0  17456   3748  19280 100188    0    0     0     0      96   348
6    1    93  0
 2  0  17456   3748  19288 100180    0    0     0    76  101   353    12
1    85  2
 0  0  17456   3748  19288 100180    0    0     0     0   105   360      8
1    91  0

for the period around the throughput slowdown. User cpu usage goes up from
around 6 % to
50 or so. Context switches jump ca 100-fold. There is no unusual swap
activity.

Top shows java -jar server.jar being responsible for the cpu utilization.

After a second or so throughput increases again to the expected levels.

Has anyone any ideas what may be happening ?

Platform is linux 64 bit (SLES 9.3) on IBM zseries. Application is a very
simple jsp reading a
couple of rows from a db2 table and displaying the result, Nothing else is
running on the server
and no other users.

Regards,

John.

=====================================
John Enevoldson

Mime
View raw message