geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Rübsam ...@coderesearch.com>
Subject Re: Errors while using Geronimo Eclipse Plugin RC2
Date Wed, 05 Jul 2006 14:28:58 GMT
Ok, I will try it with Callisto but Callisto build has some major Problems
with SWT rendering on Windows XP x64. I can't see anything on the Add Server
Dialog but I can interact with the UI. It's not a Plugin Problem it happens
in many dialogs.
Are there any ways to convert the server config from WTP 1.02 to 1.5?

Thanks,
Mario


Sachin Patel wrote:
> The plugin does no longer supports running on WTP 1.02 as there are new 
> APIs being used that are in WTP 1.5 only.  One of them which would cause 
> this problem if you ran on WTP 1.0x.
> 
> On Jul 5, 2006, at 9:15 AM, Mario Rübsam wrote:
> 
>>
>> I can confirm that problem, you can debug after the message but with 
>> limited
>> functionality also shutdown doesn't work then, you have to stop the 
>> Geronimo
>> process via the console stop function.
>>
>> Thanks,
>> Mario
>>
>>
>> Shiva Kumar H R wrote:
>>> Hi,
>>> I am using 
>>> http://people.apache.org/dist/geronimo/eclipse/unstable/g-eclipse-plugin-1.1-RC2.zip

>>> with Eclipse 3.1.2 and WTP 1.0.2 (build  wtp-sdk-R-1.0.2-200604200208).
>>> 1) While defining a New Server, during this dialog "New Apache 
>>> Geronimo v1.1 Runtime: Please enter the directory where Geronimo is 
>>> currently installed or where you would like it to be installed." as 
>>> shown in attachment " 1.GIF", once I specify the "Application Server 
>>> Installation Directory", the upper portion of the Dialog gets reduced 
>>> in size leaving me unable to see the message/info there, as shown in 
>>> attachment "2.GIF ". Although this doesn't stop me from defining a 
>>> new server, I miss out on the information which was displayed during 
>>> that dialog.
>>> 2) After defining the server (I have the following server installed: 
>>> Geronimo 1.1 with Jetty 
>>> <http://www.apache.org/dyn/closer.cgi/geronimo/1.1/geronimo-jetty-j2ee-1.1.zip>

>>> with Sun JDK 1.4.2_08), when I try to start the server, server does 
>>> get started with the below messages in "Console" view:
>>> ---------------------------------------------------------------------------------------------------------------------------------------

>>>
>>> ...
>>> 18:22:49,519 DEBUG [GBeanSingleReference] Waiting to start 
>>> geronimo/remote-deploy-jetty/1.1/car?J2EEApplication=null,WebModule=geronimo/remote-deploy-jetty/1.1/car,j2eeType=Servlet,name=jsp

>>> because no targets are running for reference JettyServletRegistration 
>>> matching the patterns 
>>> geronimo/remote-deploy-jetty/1.1/car?J2EEApplication=null,j2eeType=WebModule,name=geronimo/remote-deploy-jetty/1.1/car

>>> 18:22:49,649 DEBUG [GBeanSingleReference] Waiting to start 
>>> geronimo/remote-deploy-jetty/1.1/car?J2EEApplication=null,WebModule=geronimo/remote-deploy-jetty/1.1/car,j2eeType=Servlet,name=file-upload

>>> because no targets are running for reference Previous matching the 
>>> patterns 
>>> geronimo/remote-deploy-jetty/1.1/car?J2EEApplication=null,WebModule=geronimo/remote-deploy-jetty/1.1/car,j2eeType=Servlet,name=404-error

>>> Geronimo startup complete
>>> ---------------------------------------------------------------------------------------------------------------------------------------

>>>
>>> However the "Servers" view still shows the server status as 
>>> "Starting.." as shown in attachment " 3.GIF". And after a while, an 
>>> Error message "Timeout waiting for Apache Geronimo 1.1 to start. 
>>> Server did not start after 240000s." (as shown in attachment "4.GIF") 
>>> gets thrown. The ".log" file in "eclipse\workspace\.metadata" 
>>> directory has the following messages logged:
>>> ---------------------------------------------------------------------------------------------------------------------------------------

>>>
>>> !SESSION 2006-07-05 17:53:56.827 
>>> -----------------------------------------------
>>> eclipse.buildId=M20060118-1600
>>> java.version=1.4.2_08
>>> java.vendor=Sun Microsystems Inc.
>>> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
>>> Command-line arguments:  -os win32 -ws win32 -arch x86
>>> !ENTRY org.eclipse.wst.server.core 4 0 2006-07-05 18:26:00.293
>>> !MESSAGE Timeout waiting for Apache Geronimo 1.1 to start. Server did 
>>> not start after 240000s.
>>> ---------------------------------------------------------------------------------------------------------------------------------------

>>>
>>> - Shiva Kumar
>>> ------------------------------------------------------------------------
>>> ------------------------------------------------------------------------
>>> ------------------------------------------------------------------------
>>> ------------------------------------------------------------------------
> 
> 
> -sachin
> 
> 
> 

Mime
View raw message