geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Krishnakumar B" <www....@gmail.com>
Subject Re: Geronimo clustering
Date Mon, 10 Jul 2006 12:42:32 GMT
hi,

Have set the required properties in app, jvmRoute etc..

The log shows this

16:46:03,810 INFO  [JvmRouteBinderValve] JvmRouteBinderValve started
16:46:04,175 INFO  [DeltaManager] Register manager
/servlet-examples-cluster to cluster element unknown with name
/servlet-examples-cluster
16:46:04,176 INFO  [DeltaManager] Starting clustering manager at
/servlet-examples-cluster
16:46:04,176 INFO  [DeltaManager] Manager [/servlet-examples-cluster]:
skipping state transfer. No members active in cluster group.

Does this message mean something is not correct.
16:46:04,176 INFO  [DeltaManager] Manager [/servlet-examples-cluster]:
skipping state transfer. No members active in cluster group.

I still get only 1 value replicated.

Regards
Krish


On 7/10/06, Santosh Koti <Santosh_Koti@infosys.com> wrote:
>
>
> Hi Krishna,
>
> Well , can u do this way:
>
> 1) Stop both ur servers
> 2) Start server server1
> 3) Aftter server server1 is up, start ur server 2
> 4) in ur server2 startup console, u should something like
> deltamanager[/contextroot]...
>
> 5)Chk ur app...?
> 6) Have u set jvmroute in config.xml of server2..?
>
> PS: U shd not get smething like jvmRoute2 bind /whatever else...?!!
>
>
>
> Thanks,
> Santosh.
> "Don't talk about yourself; it will be done when you leave. "
>
>
> -----Original Message-----
> From: Krishnakumar B [mailto:www.bkk@gmail.com]
> Sent: Monday, July 10, 2006 3:55 PM
> To: user@geronimo.apache.org
> Subject: Geronimo clustering
>
> Hi,
>
> I am trying out geronimo clustering example. I seem to have a problem
> with Session Failover.
>
> I am using Apache HTTP server 2.0.58 and mod_jk 1.2.15 and geronimo 1.1
>
> I create two session variables in server 1 - server1-1 = 1 & server1-2 =
> 2
> I stop server1. Only server1-2 = 2 replicated in server 2.
> Now i add a new variable in server2 server2-1 = 1
> Now i start server1
> Now i stop server2
> I should have server1-1=1, server1-2=2 and server2-1=1 in server1
> Instead i have only server2-1=1 in server1
>
> I am not sure if i am doing something wrong. I have set jvmRoute in
> config.xml, given correct IP address in cluster application plan and
> setup workers.properties.
>
> I get these messages in server2
> 15:38:37,452 WARN  [JvmRouteBinderValve] No engine jvmRoute attribute
> configured!
> and
> 15:30:57,791 INFO  [DeltaManager] Manager
> [/servlets-examples-cluster]: skipping state transfer. No members
> active in cluster group.
> though both members of cluster are up and i am able to ping both
> machines. there are in same subnet.
>
> Thanks for any pointers...
>
> Regards
> Krish
>
> **************** CAUTION - Disclaimer *****************
> This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the
use of the addressee(s). If you are not the intended recipient, please notify the sender by
e-mail and delete the original message. Further, you are not to copy, disclose, or distribute
this e-mail or its contents to any other person and any such actions are unlawful. This e-mail
may contain viruses. Infosys has taken every reasonable precaution to minimize this risk,
but is not liable for any damage you may sustain as a result of any virus in this e-mail.
You should carry out your own virus checks before opening the e-mail or attachment. Infosys
reserves the right to monitor and review the content of all messages sent to or from this
e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys
e-mail system.
> ***INFOSYS******** End of Disclaimer ********INFOSYS***
>

Mime
View raw message