geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lin Sun" <>
Subject RE: daytrader with Tranql Oracle XA resource adapter
Date Thu, 06 Jul 2006 18:00:32 GMT
Hi, I think I ran into the same problem with the generic adapter too.   I
didn’t wait longer than 20 minutes but I know the data was not committed in
the first 20 minutes, unless you reinstall the app or shutdown the server.




-----Original Message-----
From: Manu George [] 
Sent: Thursday, July 06, 2006 2:42 AM
Subject: Re: daytrader with Tranql Oracle XA resource adapter


  I have faced the same problem using the generic adapter which got solved
on setting CommitBeforeAutCommit to true. The commits used to happen on
shutting down the app or the server though.


On 7/6/06, Mario Rübsam <> wrote:

I don't have experience with the Oracle Adapter. Can you log the commits on
the Oracle side to see if any commits come through? I had a similar problem
with MaxDB and it seems that the transactions are not closed because the 
JDBC driver for MaxDB did no commit on the connection if the AutoCommit was
switched from false to true. The JDBC spec says if the value changed the
connection must be commited but the driver does not. Thats why I use 
CommitBeforeAutCommit now.
Can you try to use the generic adapter to connect to Oracle and see if it
happens also?


Lin Sun wrote:
> Hi there,
> Thanks - I remember seeing your posting on CommitBeforeAutCommit setting
> the generic adapter.    The CommitBeforeAutCommit setting is not avail in
> the Oracle XA resource adapter.
> Lin
> -----Original Message-----
> From: Mario Rübsam [mailto:]
> Sent: Thursday, June 29, 2006 4:56 PM
> To:
> Subject: Re: daytrader with Tranql Oracle XA resource adapter 
> Hi,
> the CommitBeforeAutCommit setting in the generic adapter call
> a commit on the local connection before it calls setAutoCommit(true).
> Some JDBC drivers act not like specified in JDBC and don't call 
> a commit when the AutoCommit value changes with setAutoCommit(true)
> so CommitBeforeAutCommit is a workaround to get the transaction
> commited on these drivers (MySQL, MaxDB, PostgreSQL in some cases). 
> I don't know about the XA driver and Oracle but it could be a similar
> problem.
> -Mario
> Lin Sun wrote:
>> Hi there,
>> I have been playing with the daytrader with Tranql Oracle XA resource 
>> adapter (tranql-connector-oracle-xa-1.1.rar).  After I tweaked the
>> plan a bit and I am able to get daytrader running well with oracle!
>> One thing I noticed is that if I perform any trading activities as a 
>> user (say uid:1, account_id 50), I get the message that my order has
>> been completed almost immediately.  However, the order isn't committed
>> into the oracle database until quite a while.  I don't know the exact 
>> timing but seems to be over 20-30 minutes.
>> Here is what I did to check if the order is recorded in the database:
>> Select * from orderejb where account_id=50;
>> If the order is committed into the database, I would expect a row that
>> represents my previous order to be returned as the output of the sql
>> command.
>> If I run the same scenario with db2 or derby, I can see my order 
>> recorded in the orderejb table immediately.
>> I looked at the tranql oracle vendor code but I didn't see anywhere
>> specifying the commit timing thing.  The generic resource adapter does 
>> offer an param called CommitBeforeAutCommit and by setting it to true
>> would force the commit to happen immediately.   Can someone shed some
>> light on this?
>> Thanks, Lin 


View raw message