geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: problem looking up connection factory from a war
Date Thu, 08 Jun 2006 20:51:16 GMT
Probably you are missing a dependency from your app to the activemq  
configuration.  In 1.1 resource references need to be resolvable in  
the set of ancestors of your module.  In other words, your app has to  
depend on the rar deployment.

Make sure your plan includes something like
<environment>
...
<dependencies>
   <dependency>
     <groupId>geronimo</groupId>
     <artifactId>activemq</artifactid>
   </dependency>
...
<dependencies>
</environment>

Hope I got all the names right :-)
version is unnecessary

thanks
david jencks

On Jun 8, 2006, at 1:41 PM, Christoph Sturm wrote:

> hey!
>
> i have this in my web.xml:
>
>    <resource-ref>
>        <res-ref-name>ConnectionFactory</res-ref-name>
>        <res-type>javax.jms.ConnectionFactory</res-type>
>        <res-auth>Container</res-auth>
>        <res-sharing-scope>Shareable</res-sharing-scope>
>    </resource-ref>
>
> and this in my geronimo-web.xml:
>
>    <n:resource-ref>
>        <n:ref-name>ConnectionFactory</n:ref-name>
>        <n:resource-link>DefaultActiveMQConnectionFactory</ 
> n:resource-link>
>    </n:resource-ref>
>
> and when i deploy the war i get this error:
>
> org.apache.geronimo.common.DeploymentException: Unable to resolve
> resource reference 'ConnectionFactory' (Could not find resource
> 'DefaultActiveMQConnectionFactory'.  Perhaps it has not yet been
> configured, or your application does not have a dependency declared
> for that resource module?)
>
> (I am using the geronimo 1.1 candidate)
>
> what am i doing wrong?
>
> thanks
> chris
> -- 
> christoph.sturm@gmail.com


Mime
View raw message