geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christoph Sturm" <christoph.st...@gmail.com>
Subject jms problem: No ManagedConnections available within configured blocking timeout
Date Tue, 20 Jun 2006 18:25:29 GMT
hey guys!

I am using geronimo 1.1 (the final-2 candidate release), and i am
using lingo for spring remoting over jms. When i invoke a call i get
this stacktrace:

javax.jms.JMSException: No ManagedConnections available within
configured blocking timeout ( 5000 [ms] )
        at org.activemq.ra.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:98)
        at org.activemq.ra.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:67)
        at $javax.jms.ConnectionFactory$$FastClassByCGLIB$$ba089bf6.invoke(<generated>)
        at net.sf.cglib.proxy.MethodProxy.invoke(MethodProxy.java:149)
        at org.apache.geronimo.connector.ConnectorMethodInterceptor.intercept(ConnectorMethodInterceptor.java:54)
        at $javax.jms.QueueConnectionFactory$$EnhancerByCGLIB$$820bd112.createConnection(<generated>)
        at org.logicblaze.lingo.jms.impl.DefaultJmsProducer.newInstance(DefaultJmsProducer.java:38)
        at org.logicblaze.lingo.jms.impl.MultiplexingRequestor.newInstance(MultiplexingRequestor.java:62)
        at org.logicblaze.lingo.jms.JmsClientInterceptor.createRequestor(JmsClientInterceptor.java:371)
        at org.logicblaze.lingo.jms.JmsClientInterceptor.afterPropertiesSet(JmsClientInterceptor.java:125)
        at org.logicblaze.lingo.jms.JmsProxyFactoryBean.afterPropertiesSet(JmsProxyFactoryBean.java:42)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:810)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:779)
        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:360)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:226)
        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:147)
        at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:256)
        at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:331)
        at org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:87)
        at org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:72)

maybe the problem is lingo related, but the application works fine
with jboss 4.x and using jbossmq.

Does anyone have an idea what could be causing this?

thanks
 chris

Mime
View raw message