Thanks Much Aaron & Erin, it was helpful !!
 
--Maryam

 
On 5/4/06, Aaron Mulder <ammulder@alumni.princeton.edu> wrote:
First of all, M5 is quite old.  You should certainly be using the 1.0
final release at a minimum.  There's a 1.1 prerelease available and
hopefully 1.1 final will be available "soon".

That aside, the UnsupportedClassVersionError means that some code was
compiled under JDK 1.5 and you're tring to run it under JDK 1.4.
Specifically, it looks like MovieGridManagerPortTypeMessageReceiver
was compiled under JDK 1.5.  You shoudl either compile that under JDK
1.4, or run Geronimo under JDK 1.5 in order to eliminate this error.

Thanks,
    Aaron

On 5/4/06, Maryam Moazeni <mmoazeni@gmail.com> wrote:
>
> Hi,
>
> I have geronimo-1.0-M5 and axis2-0.92 on my system,
> when I tried to upload the services's .aar file, I got this error from
> Geronimo:
>
> java.lang.UnsupportedClassVersionError:
> com/ibm/grid/moviegridmanager/MovieGridM
> anagerPortTypeMessageReceiver (Unsupported major.minor version 49.0)
>         at java.lang.ClassLoader.defineClass0(Native
> Method)
>         at java.lang.ClassLoader.defineClass(Unknown
> Source)
>         at
> java.security.SecureClassLoader.defineClass (Unknown Source)
>         at java.net.URLClassLoader.defineClass(Unknown
> Source)
>         at java.net.URLClassLoader.access$100 (Unknown
> Source)
>         at java.net.URLClassLoader$1.run (Unknown Source)
>         at
> java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(Unknown
> Source)
>         at
> org.apache.axis2.deployment.DeploymentClassLoader.findClass (Deploymen
> tClassLoader.java:119)
>         at java.lang.ClassLoader.loadClass(Unknown Source)
>         at java.lang.ClassLoader.loadClass(Unknown Source)
>          at java.lang.ClassLoader.loadClassInternal (Unknown
> Source)
>         at java.lang.Class.forName0(Native Method)
>         at java.lang.Class.forName(Unknown Source)
>         at
> org.apache.axis2.deployment.DescriptionBuilder.loadMessageReceiver
> (De
> scriptionBuilder.java:300)
>         at
> org.apache.axis2.deployment.ServiceBuilder.processOpeartions(ServiceB
> uilder.java:184)
>         at
> org.apache.axis2.deployment.ServiceBuilder.populateService (ServiceBui
> lder.java:124)
>         at
> org.apache.axis2.deployment.repository.util.ArchiveReader.buildServic
> eGroup(ArchiveReader.java:275)
>         at
> org.apache.axis2.deployment.repository.util.ArchiveReader.processServ
>  iceGroup(ArchiveReader.java:220)
>         at
> org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngin
> e.java:601)
>         at
> org.apache.axis2.deployment.repository.util.WSInfoList.update (WSInfoL
> ist.java :219)
>         at
> org.apache.axis2.deployment.listener.RepositoryListenerImpl.update(Re
> positoryListenerImpl.java:142)
>         at
> org.apache.axis2.deployment.listener.RepositoryListenerImpl.startList
> ent(RepositoryListenerImpl.java :164)
>         at
> org.apache.axis2.deployment.scheduler.SchedulerTask.checkRepositary(S
> chedulerTask.java:54)
>         at
> org.apache.axis2.deployment.scheduler.SchedulerTask.run (SchedulerTask
> .java:50)
>         at
> org.apache.axis2.deployment.scheduler.Scheduler$SchedulerTimerTask.ru
> n(Scheduler.java:40)
>         at java.util.TimerThread.mainLoop(Unknown Source)
>         at java.util.TimerThread.run(Unknown Source)
>
> ********************************************************************************************************************
> ********************************************************************************************************************
>
> Also when I was deploying Axis2 to Geronimo I got this warning :
>
> 17:26:02,078 WARN  [JettyModuleBuilder] Web application does not contain a
> WEB-I
> NF/geronimo-web.xml deployment plan.  This may or may not be a problem,
> depending
> on whether you have things like resource references that need to be
> resolved.
> You can also give the deployer a separate deployment plan file on the
> command line.
>
> I would appericate if some one could help me figure out this poblem.
>
> Thanks in advance
>
> --Maryam
>