geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anshuk Chinmoy Pal Chaudhuri" <Anshuk_PalChaudh...@infosys.com>
Subject RE: Stuck in deploying MDB
Date Mon, 22 May 2006 08:24:04 GMT
When I deploy org/apache/geronimo/SystemJMS project. Geronimo report
error that...:

 
D:\geronimo-1.0\bin>java -jar deployer.jar start
org/apache/geronimo/SystemJMS
Username: system
Password:
 
    Error: org/apache/geronimo/SystemJMS does not appear to be a the
    name of a module available on the selected server. Perhaps it has
    already been stopped or undeployed?  If you're trying to specify a
    TargetModuleID, use the syntax TargetName|ModuleName instead. If
    you're not sure what's running, try the list-modules command.

Any pointers what kind of error is that?
How do I register the project with config id
org/apache/geronimo/SystemJMS?
If I dont then I wont be able to deploy MDB on the server.

Warm Regards, 
Anshuk Pal Chaudhuri 
SETLabs - Web Services CoE


________________________________

From: Anshuk Chinmoy Pal Chaudhuri
[mailto:Anshuk_PalChaudhuri@infosys.com] 
Sent: Monday, May 22, 2006 11:06 AM
To: user@geronimo.apache.org
Subject: Stuck in deploying MDB





<<ejb-jar.xml>> <<JMS_CLIENT_MDB_LISTENER_DEPLOYMENT_PLAN.xml>>
<<openejb-jar.xml>> 
Hi, 

I am having some issues in deploying MDB's on Geronimo 1.0 reagrding the
parent id. 
I do not have ear application files as such.Just a simple MDB listening
to a queue. 

I have created the queues (which is mentioned in the MDB config files)
using the resource adapater file from the activemq-ra-3.2.1 file.

The resource adapter file contains the parent id:
geronimo/activemq-broker/1.0/car 

The parent id of the MDB deployment file has to be
org/apache/geronimo/SystemJMS otherwise it will throw an error of
java.lang.ClassNotFoundException:
org.activemq.ra.ActiveMQActivationSpec,true. But while deploying the MDB
using the parent id: org/apache/geronimo/SystemJMS,there is an error
saying that Unable to load first parent of configuration TESTING_JMS_MDB
No configuration with id: org/apache/geronimo/SystemJMS 

I have attached the configuration files: 

*	JMS_CLIENT_MDB_LISTENER_DEPLOYMENT_PLAN.xml (resource adapter
file to create queues) 
*	ejb-jar.xml 
*	openejb-jar.xml 
	

The default activemq-broker application is running. 
Is it to do with that or something? 
Can somebody let me know asap what else configuration do I need to make
to make that working? 


Warm Regards, 
Anshuk Pal Chaudhuri 

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended
solely for the use of the addressee(s). If you are not the intended
recipient, please notify the sender by e-mail and delete the original
message. Further, you are not to copy, disclose, or distribute this
e-mail or its contents to any other person and any such actions are
unlawful. This e-mail may contain viruses. Infosys has taken every
reasonable precaution to minimize this risk, but is not liable for any
damage you may sustain as a result of any virus in this e-mail. You
should carry out your own virus checks before opening the e-mail or
attachment. Infosys reserves the right to monitor and review the content
of all messages sent to or from this e-mail address. Messages sent to or
from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***
	

Mime
View raw message