Hi Aaron,
 
Thanks for your quick reply.  I tried your suggestion and added a dependency element in the deployment plan and copied GBean1.jar into geronimo/repository/GBean1/jars and I did not pass the JAR file to the deployer.  The following is the modified deployment plan.
 
<?xml version="1.0" encoding="UTF-8"?>
<configuration configId="GBean1">
<dependency>
<uri>GBean1/jars</uri>
</dependency>
<gb:gbean xmlns:gb=" http://geronimo.apache.org/xml/ns/deployment-1.0" name="geronimo.server:type=GBean" class="com.businessobjects.geronimo.GBean1">
 <gb:attribute name="attribute1" type="java.lang.String">
 test1
 </gb:attribute>
</gb:gbean> 
</configuration>
 
I also tried putting GBean1/jars and GBean1/jars/GBean1.jar as the uri, but both times I got the following error:
 
 Error: Unable to distribute GBean1-plan.xml: Cannot deploy the
 requested application module
 (planFile=D:\geronimo-1.0\GBean1-plan.xml)
 
Any suggestion you can give will be greatly appreciated.  Thanks.
 
Ye
 
 
On 4/6/06, Aaron Mulder <ammulder@alumni.princeton.edu> wrote:
You can't pass a JAR and plan to the deployer for a custom GBean.
Instead, you need to install the JAR under geronimo/repository and
refer to it from a dependency element in the plan for the GBean.  Does
that make sense or do you need some more detailed help?

Thanks,
   Aaron

On 4/6/06, Ye Lu < yel728@gmail.com> wrote:
>
> Hi,
>
> I am currently running Geronimo 1.0.  When I tried to deploy a GBean using
> the command "java -jar bin\deployer.jar --user system --password manager
> deploy d:\geronimo-1.0\repository\GBean1\jars\GBean1.jar
> GBean1-plan.xml ", I got the following error:
>
>     Error: Unable to distribute GBean1.jar: Cannot deploy the requested
>     application module (planFile=D:\geronimo- 1.0\GBean1-plan.xml,
>
> moduleFile=D:\geronimo-1.0\var\temp\geronimo-deployer382.tmpdir\GBean1.jar
> )
>
> My deployment plan is
>
> <?xml version="1.0" encoding="UTF-8"?>
> <configuration configId="GBean1">
> <gb:gbean
> xmlns:gb="http://geronimo.apache.org/xml/ns/deployment-1.0
> " name=" geronimo.server:type=GBean"
> class="com.businessobjects.geronimo.GBean1">
>  <gb:attribute name="attribute1" type="java.lang.String">
>  test1
>  </gb:attribute>
> </gb:gbean>
> </configuration>
>
> I did a quick trace into the source code and found that the value of builder
> after the following loop is null and that cause the exception to be thrown.
>
> Object plan = null;
>             ConfigurationBuilder builder = null;
>             for (Iterator i = builders.iterator(); i.hasNext();) {
>                 ConfigurationBuilder candidate = (ConfigurationBuilder)
> i.next();
>                 plan = candidate.getDeploymentPlan(planFile, module);
>                 if (plan != null) {
>                     builder = candidate;
>                     break;
>                 }
>             }
>
> Can you tell me what I have done wrong?  Thanks in advance.
>
>
> Ye