geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From avin98 <avi...@yahoo.com>
Subject Re: Geronimo xmlbeans error
Date Fri, 28 Apr 2006 19:07:44 GMT

Finally I figured out what was wrong.

In the Geronimo deployment, you need to specify the dependency as:

  <dep:dependency
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.0">
    <dep:groupId>xmlbeans</dep:groupId>
    <dep:artifactId>xbean</dep:artifactId>
    <dep:version>2.0.0</dep:version>
  </dep:dependency>
  
  <dep:dependency
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.0">
    <dep:groupId>stax</dep:groupId>
    <dep:artifactId>stax-api</dep:artifactId>
    <dep:version>1.0</dep:version>
  </dep:dependency>

Drop in the stax-api-1.0.jar into "C:\WebsphereCE\repository\stax\jars"

What I am not sure though, is why the xmlbeans jar never got picked up, when
my WEB-INF/lib directory contained the xmlbean jars & stax-api resolvers.

Thanks a lot David & Aaron for all your help and suggestions.

--
View this message in context: http://www.nabble.com/Geronimo-xmlbeans-error-t1522515.html#a4146079
Sent from the Apache Geronimo - Users forum at Nabble.com.


Mime
View raw message