geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Clough, Ray C PWR" <Ray.Clo...@pwr.utc.com>
Subject RE: Geronimo Problem
Date Tue, 04 Apr 2006 20:26:52 GMT
You're right.  I renamed the oracle jdbc jar file from ojdbc14.jar to
ojdbc-14.jar, and it all started working.  That is a pretty touchy error
source, because it was also preventing postgresql from working.  I
couldn't even get a data-entry form (page 2 in the wizard) for derby,
but once I changed the oracle driver name, everything worked.

One comment, the db pool wizard has fixed fields for each data item:
host, port, ...  It would be nice to have a single box (as an alternate)
where you could enter the entire url string.  I've got a complex string,
with failovers, etc from our DBA, and there was no way to directly enter
it.  I had to save the deployment plan and edit it.

Thanks, Aaron.  You saved me and my bacon.

- Ray Clough
 

-----Original Message-----
From: ammulder@gmail.com [mailto:ammulder@gmail.com] On Behalf Of Aaron
Mulder
Sent: Tuesday, April 04, 2006 12:58 PM
To: user@geronimo.apache.org
Subject: Re: Geronimo Problem

Can you see if the server console output shows any errors, or if not, if
the server log file at var/log/geronimo.log shows any errors? 
Usually if a screen shows up blank there was an exception that prevented
it from rendering and the stack trace is in the log.

Again, in 1.0, this may be caused by a badly-named JAR in the
repository.  Or it may be something else.  :)

Thanks,
    Aaron

On 4/4/06, Clough, Ray C             PWR <Ray.Clough@pwr.utc.com> wrote:
> Here is a pdf of the screen shots.  As you can see, the 2nd screen is 
> just empty.
>
> Thanks.
>
> - Ray Clough
>
>
> -----Original Message-----
> From: ammulder@gmail.com [mailto:ammulder@gmail.com] On Behalf Of 
> Aaron Mulder
> Sent: Tuesday, April 04, 2006 12:24 PM
> To: Geronimo User
> Subject: Re: Geronimo Problem
>
> Can you walk me through screen by screen what you enter in which field

> and what screen it takes you to after you click next?
>
> We have had a problem with the Tomcat version of Geronimo where if 
> there are certain characters in the connect URL then the database 
> wizard breaks and returns to the database pool list screen in the 
> middle (that is fixed for 1.1).  If that's what you're running into 
> then switching to the Jetty version should help for now.  If not, 
> please also check the server log (var/log/geronimo.log) for stack 
> traces or error messages while you're gong through the database
wizard.
>
> I'm not sure what to say about the problem with Oracle or PostgreSQL.
> Can you say exactly what file paths/names you saved the JDBC driver 
> JARs to and what entry you picked for the driver JAR on the screen 
> where it prompts you for the driver class, driver JAR, etc.?
>
> I guess this reminds me -- I think some of the admin console screens 
> barf if you put a JAR in the repository with the wrong name format.
> This may also be causing your problems.  Make sure each file has a 
> dash then a version number in the name 
> (repository/oracle/jars/oracle-9ir2.jar not 
> repository/oracle/zips/classes.zip or something like that).  We also 
> have a fix in 1.1 to handle this situation better.
>
> Thanks,
>     Aaron
>
> On 4/4/06, Clough, Ray C             PWR <Ray.Clough@pwr.utc.com>
wrote:
> > I am a relatively inexperienced Geronimo user, but previously when I

> > used the Database Pool wizard, after the 1st page, I'd get detailed
> input forms.
> > Now I get nothing, with any specified db name or db type.  I tried 
> > reinstalling Geronimo, same result.
> >
> > Further, I've put the oracle and postgresql jdbc drivers under 
> > oracle/jars and postgresql/jars respectively, but Geronimo can't 
> > find the driver classes.
> >
> > Any ideas or suggestions?  Thank you very much.
> >
> > (By the way, your documentation is first rate, especially for such a

> > young
> > project.)
> >
> >
> > -Ray Clough
> > Ray.Clough@pwr.utc.com
>
>
>

Mime
View raw message