geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tomson Xu <tomso...@cityu.edu.hk>
Subject Re: Geronimo with Tomcat strange problem: can't find home page
Date Thu, 06 Apr 2006 20:54:06 GMT
Hi Paul,

Thanks for your reply. I tried to access http://localhost:8080/, the same 
error occured.

I check the var/logs/catalina/logs/localhost_access_log, the log is:
127.0.0.1 - - [07/Apr/2006:04:45:01 +0800] "GET / HTTP/1.1" 404 1076

and in the var/config/config.xml file, doesn't set load="false" to 
welcome-tomcat

But I searched the var/log/geronimo.log file and can't find the key word 
"welcome-tomcat". Is it the reason? I tried to Geronimo with Jetty and 
checked the geronimo.log file, the key word "welcome-jetty" can't be found, 
either. but home page is accessed successfully.

I use another machine to test geronimo with tomcat, it is ok to access home 
page. very strange. :(


Regards,
Tomson

----- Original Message ----- 
From: "Paul McMahan" <paulmcmahan@gmail.com>
To: <user@geronimo.apache.org>
Sent: Friday, April 07, 2006 1:58 AM
Subject: Re: Geronimo with Tomcat strange problem: can't find home page


If you add a slash to the end of the URL do you get the same result?
e.g. http://localhost:8080/
I'm wondering if your browser might be sending a request that tomcat
doesn't understand when the trailing slash is omitted.  Seems unlikely
but possible.

Other things to check:
-  Look in var/logs/catalina/logs/localhost_access_log* to see how
tomcat logs your request.  It should look something like:  ... "GET /
HTTP/1.1" 200 12990
-  Look at var/log/geronimo.log to see if there's anything suspicious
related to the welcome app
-  Look in var/config/config.xml to make sure there's an entry for
welcome-tomcat (which doesn't specify load="false")

Best wishes,
Paul

On 4/6/06, Tomson Xu <tomsonxu@cityu.edu.hk> wrote:
>
> I downloaded Geronimo with Tomcat 1.0 and started it with jdk1.4.2. When I
> try to access url: http://localhost:8080, "HTTP Status 404" occured, but
> access geronimo console (http://localhost:8080/console) is OK. And access
> servlet example url:
> http://localhost:8080/servlets-examples is also OK. It
> seems that only the home page is wrong. I checked admin console "Web App
> WARs" node, "geronimo/welcome-tomcat/1.0/car" component is running.
>
> I tried Geronimo with jetty, home page is OK. How to solve the strange
> problem? Thanks.
>
> Best Regards,
>
> Tomson
>


Mime
View raw message