geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjen van der Weijden <Arjen.van.der.Weij...@rivm.nl>
Subject Re: Lion won't roar: eclipse plugin
Date Fri, 24 Mar 2006 08:02:08 GMT
Hi George,

I guess we're both in the same (little) league :).

No luck, I've been at it for two days as well, but I'm not giving up (yet).
Sachin has some ideas about this I believe.


thanx,

Arjen


|-------------------------------------->
|            "George Lee"              |
|            <georgewslee@gmail.com>   |
|                                      |
|            2006-03-24 02:44 AM       |
|                                      |
|                                      |
|                Please respond to     |
|             user@geronimo.apache.org |
|                                      |
|-------------------------------------->
  >-----------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                          |
  |                                                                                      
                          |
  |                                                                                      
                        To|
  |        user@geronimo.apache.org                                                      
                          |
  |                                                                                      
                        cc|
  |                                                                                      
                          |
  |                                                                                      
                   Subject|
  |        Re: Lion won't roar: eclipse plugin                                           
                          |
  |                                                                                      
                          |
  >-----------------------------------------------------------------------------------------------------------------|




Hi Arjen,

Any luck? I encountered the same problem as you did.

After deploying the EJB Project to the server, the test.jsp encounters an
error where com.zoo cannot be found.

I noticed that ZooBeansClient package  won't be created unless you include
ur EJB Project into and EAR. So I proceeded to include the EJB project and
web project into my EAR. I hit a diff. error this time...

when I tried to deploy the EAR to the server,  geronimo reported the
following error...

java.lang.ClassFormatError: com/zoo/Tiger (Illegal field modifiers: 0x2)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass (SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
....etc. etc.


What is wrong with the class Tiger is beyond me. I've tried everything i
can for 2 days with no luck.


Its just a JSP that invokes a EJB method that prints "Roar!" and all EJB
classes were generated by xDoclet-EJB and I can't get it to work. I can't
help but feel that I am an idiot for not being able to get something so
simple working. Did I miss out something trivial?


Can anyone help? I can send you the .ear file with all source code
included.


Thanks!

cheers,
George

On 3/23/06, Arjen van der Weijden <Arjen.van.der.Weijden@rivm.nl> wrote:
  It won't even miaow :)

  Trying to get ahead with eclipse and apache I followed the ( eclipse.org)
  tutorial for building a simple EJB application (for JBOSS server).
  Since we're using WTP it doesn't matter which J2EE-server is targetted.
  Despite minor differences between the WTP version described and the one I

  use, there are some offsets I've stumbled upon:

  1) I don't see the ZooBeansClient package being created. All classes are
  within my ZooBeansProject (so it seems)


  The deployment of the EJB goes well, and is visible in the console:

  ZooBeansproject/ZooBeansproject running Stop Uninstall


  So I've added

  <dependent-module deploy-path="/WEB-INF/lib"
       handle="module:/resource/ZooBeansProject/ZooBeansProject">
         <dependency-type>uses</dependency-type>
     </dependent-module>

  to the .component file        .

  2) Running the ZooWeb test.jsp gave me an error that it could not find
  the
  com.zoo package.

  com.zoo.Tiger cannot be resolved or is not a type


  What am I missing? Are there some good tutorials and articles out there
  that can help me out?


  thanx,

  Arjen




Mime
View raw message