geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arjen van der Weijden <Arjen.van.der.Weij...@rivm.nl>
Subject Re: eclipse plugin
Date Tue, 21 Mar 2006 14:28:00 GMT
Another question. Got the server up and running on j2sdk1.4.2 from within
eclipse, and continued following the guidelines on deploying a minimal
application with just one html file. The "run as" command should deploy and
run the app but unfortunately nothing get deployed. Does anybody knows
howto perform the last and crucial step?

thanks,

Arjen



|-------------------------------------->
|            Arjen van der Weijden     |
|            <Arjen.van.der.Weijden@riv|
|            m.nl>                     |
|                                      |
|            2006-03-20 05:17 PM       |
|                                      |
|                                      |
|                Please respond to     |
|             user@geronimo.apache.org |
|                                      |
|-------------------------------------->
  >-----------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                          |
  |                                                                                      
                          |
  |                                                                                      
                        To|
  |        user@geronimo.apache.org                                                      
                          |
  |                                                                                      
                        cc|
  |                                                                                      
                          |
  |                                                                                      
                   Subject|
  |        Re: eclipse plugin                                                            
                          |
  |                                                                                      
                          |
  >-----------------------------------------------------------------------------------------------------------------|




Thanks sachin! I'll have a look at it.


|-------------------------------------->
|            Sachin Patel              |
|            <sppatel2@gmail.com>      |
|                                      |
|            2006-03-20 05:04 PM       |
|                                      |
|                                      |
|                Please respond to     |
|             user@geronimo.apache.org |
|                                      |
|-------------------------------------->

>-----------------------------------------------------------------------------------------------------------------|

  |
|
  |
|
  |
To|
  |        user@geronimo.apache.org
|
  |
cc|
  |
|
  |
Subject|
  |        Re: eclipse plugin
|
  |
|

>-----------------------------------------------------------------------------------------------------------------|





Yes, this article is outdated, and I should remove the reference to
it or better update it. :)  The reference to the plugin
org.eclipse.jst.server.geronimo.core was valid when the geronimo
eclipse plugin was part of WTP in its 0.7 release.  The UI in WTP
from .7 to 1.0.1 has changed significantly as well.

The easiest way to get started is to simply download the all-in-one
package of WTP 1.0.1 (this includes all the prereqs).  Once you've
started up a workbench, when defining a new runtime you'll see a link
"Don't see your server listed?", click this and you'll see geronimo
and hit Install.  This will install the geronimo plugins you need
automatically.

- sachin



On Mar 20, 2006, at 7:57 AM, Arjen van der Weijden wrote:

>
>
> I've been studying the article
> http://www-128.ibm.com/developerworks/opensource/library/os-
> gerplug/ that
> describes howto quickly get started creating geronimo apps with
> eclipse.
> The article mentions the geronimo plugin
> org.eclipse.jst.server.geronimo.core_1.0.0, but I couldn't find it
> at the
> referred locations. It seems the world has changed since the writing.
>
> In the geronimo wiki I've found the following: "The above article
> refers to
> ongoing development of this plugin as part of Eclipse's Web Tools
> project.
> However as of recent, this is no longer, and it has been removed
> from WTP
> drivers. Instead, it is now being developed as a subproject under
> Apache
> Geronimo."
>
> I came accross this geromnimo plugin at the apache site:
> geronimo-eclipse-plugin-1.0.0.zip (unstable version) which unpacked
> delivers me the package org.apache.geronimo.runtime.v1_1.0.0.
>
> I installed this plugin with all the WTP-prerequisites and WTP itself.
> Doesn't seem to work as described by ibm.
>
>
> Question: Is this plugin the same as the ibm article describes?
>
>
> thanks,
>
> Arjen
>
>
>
>
> ______________________________________________________________________
> ______
>
> DISCLAIMER:  http://www.rivm.nl/disclaimer.htm
>






Mime
View raw message