geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: geronimo and eclipse wtp
Date Fri, 24 Mar 2006 13:39:47 GMT
Your error is most likely due to you using a 1.5 JRE.  You cannot  
launch eclipse using a 1.5 JRE and will need to fall back on using  
1.4.x either by setting your system default, using the -vm argument  
or copying the 1.4x jre directory into your eclipse installation.   
This problem will be addressed in future releases.

- sachin



On Mar 24, 2006, at 8:00 AM, Pablo wrote:

> Hello everyone
>
> I've been trying to use wtp plugin for eclipse to run my web  
> application with no success so far.
> wtp and Apache tomcat 5.5.x works fine however geronimo doesn't.
>
> So I wanted to run the simplest possible web application on  
> geronimo using wtp plugin.
> Created a webapp with an index.html file.
> Then I start the geronimo server (jetty) and when it's running I  
> choose "Run on server" from index.html's context menu (from a  
> tutorial).
> Of course I choose geronimo and press finish. Unfortunatelly I got  
> message:
> HTTP ERROR: 404 Not Found
> RequestURI=/wtp_tutorial/index.html
>
> Powered by Jetty://
>
> Of course the server is working fine, I can log into console,  
> deploy web applications and everything works fine. But not with wtp  
> plugin.
> When I create a war from this example web application and deploy it  
> in geronimo using console then I index.html shows up so the  
> appliacation works fine.
>
> The question is, what am I doing wrong that I can't use geronimo in  
> wtp eclipse plugin ?
> When I try to use a web app in eclipse with geronimo, the project  
> is not deployed in geronimo. There is no evidence of such project  
> in the console in:
> Application
> |--->Web App WARs
>
> I'm using geronimo-1.0-jetty with wtp 1.0.1, eclipse 3.2m4
>
> Cheers
> Pablo
>


Mime
View raw message