geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: NoClassDefFoundError deployment errors
Date Fri, 17 Mar 2006 17:55:45 GMT

On Mar 17, 2006, at 9:23 AM, Richard Wallace wrote:

> Greetings all,
>
> I'm new to Geronimo.  I'm trying to deploy one of my web  
> applications that had previously just been deployed in a standalone  
> tomcat container in Geronimo 1.0.  I've tried this with both the  
> version with Jetty and with Tomcat bundled.  The web app uses a  
> Hibernate/Spring/JSF framework stack.  The jars for each project  
> are bundled in the war file in the WEB-INF/lib directory.
> But when I deploy the application I'm getting NoClassDefFoundErrors  
> for javax/faces/el/VariableResolver and org/hibernate/ 
> HibernateException.
>
> Any ideas what I'm missing here?

My first guess is that a copy of spring included in geronimo is  
getting used in your web app instead of the copy you are trying to  
use: when our copy tries to load the faces/hibernate classes it can't  
find them.  If this is the problem you should be able to fix it by  
adding spring and hibernate to the hidden classes list in your  
geronimo plan for your application.

I think the xml syntax would be (consult modules/service-builder/src/ 
schema/geronimo-config-1.0.xsd, this is also somewhere in the  
distribution such as schema/....)

<hidden-classes>
    <filter>javax.faces.el.</filter>
</hidden-classes>
<hidden-classes>
    <filter>org.hibernate.</filter>
</hidden-classes>

I regard the need for multiple hidden-classes elements as a bug in  
the schema, and it is fixed in 1.1 (which doesn't work right now)  
(but not yet in 1.2, it will be fixed there when we merge in 1.1)

thanks
david jencks

>
> Thanks,
> Rich


Mime
View raw message