geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kristian Rink <>
Subject Re: geronimo, eclipse and javax.ejb?
Date Wed, 22 Feb 2006 21:12:02 GMT

Hello Sachin, David, world;

and at first thanks a lot for your hints.

Sachin Patel schrieb:
> You need to use the Geronimo eclipse plugin that is available.  When you
> create an EJB application you need to define a Geronimo runtime and then
> target your application to that runtime.  By doing so this adds the spec
> jars so javax.ejb.* will resolve.

Okay, I installed the geronimo eclipse plugin, completely dropped my old
test project, recreated it, added the Geronimo server runtime and still
- nada. No javax.ejb.* packages known. Nothing. The packages aren't
there, and when I try to create a new EJB using "file"->"new", I get
something like that:

[ejbdoclet] XDoclet classpath missing J2EE classes
[ejbdoclet] at
[ejbdoclet] at xjavadoc.ant.XJavadocTask.execute(
[ejbdoclet] at
[ejbdoclet] at
[ejbdoclet] at
[ejbdoclet] at

Anything else that can be wrong here?

TIA and best regards,

Kristian Rink   -- Programmierung/Systembetreuung
planConnect GmbH * Strehlener Str. 12 - 14 * 01069 Dresden
0176 24472771 *

View raw message