geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajith Attapattu <rajit...@gmail.com>
Subject Re: javamail
Date Tue, 17 Jan 2006 17:50:25 GMT
Any chance that your emails were filtered by a spam filter or something.

If not,
First grep the log for MessagingExceptions (but I assume you have done that,
bcos u mentioned no errors)

Try to do the following.

Enable debug and grep the log for the following

"connecting to " + mail_host

"connected to " + mail_host

"error connecting to " + mail_host

That part gives u some sort of an indication as whether connection is ok or
not.

After that grep for ""received : ", it will give some indication of the
responses we receive from the mail server for the commands sent

These are some of the things I can think of that maybe of help to you.

If those thing don't help try the following
----------------------------------------------------------
If u want u can  remote debug using eclipse, The class to look at is
org.apache.geronimo.javamail.transport.smtp.SMTPTransport, just set a few
brake points in
getConnectedSocket, sendData, sendLine, receiveLine and see what happens. If
u find something u can open up a JIRA :)

Regards,

Rajith.


On 1/17/06, Alex Andrushchak <ustas@dekasoft.com.ua> wrote:
>
> Hi!
>
> I have problem with mailing from geronimo.
> Mail service is configured in geronimo-application.xml :
> <application
>       xmlns="http://geronimo.apache.org/xml/ns/j2ee/application"
>       configId="org/queryphone/Queryphone">
>
>    <dependency>
>        <uri>geronimo/geronimo-mail/1.0</uri>
>    </dependency>
>
>    <gbean name="jmp.smtp"
> class="org.apache.geronimo.mail.SMTPTransportGBean">
>        <attribute name="host">192.168.1.10</attribute>
>        <attribute name="port">25</attribute>
>        <attribute name="from"> geronimo@dekasoft.com.ua</attribute>
>    </gbean>
>
>    <gbean name="mail/MailSession"
> class="org.apache.geronimo.mail.MailGBean">
>        <attribute name="transportProtocol">smtp</attribute>
>        <attribute name="useDefault">true</attribute>
>        <attribute name="properties">mail.debug=true </attribute>
>        <reference name="Protocols">
>            <name>jmp.smtp</name>
>        </reference>
>    </gbean>
>
> </application>
>
> Session bean that uses mail/MailSession is implemented.
> When i'm trying to send e-mail everything is working without any errors
> but mail messages are not going to smtp server from geronimo.
> Where i'm wrong?
>
> Best regards,
> Alex Andrushchak
>
>

Mime
View raw message