geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jian Liao <norwaywo...@gmail.com>
Subject Re: How to I convert this dependency in AG 1.0
Date Thu, 12 Jan 2006 01:31:03 GMT
Try this:
repository/oracle/jars/classes12-10gr2.jar

and

<dependency>
                <uri>oracle/classes12/10gr2/jar</uri>
</dependency>

Hope it helps,

- Jian Liao

On 1/12/06, Lin Sun <linsun_unc@yahoo.com> wrote:
>
> Hi there,
>
> I have a database deployment plan for Oracle database server.  It worked
> well in Geronimo
> M5 using the generic tranql resource adapter .  I understand the
> dependency uri syntax is
> changed in Geronimo 1.0.   But i haven't been able to deploy the database
> deployment plan
> in Geronimo 1.0 yet with different tries.
>
> In my repository I have file: oracle\jars\classes12.zip
>
> The dependency elements that worked with Geronimo M5:
>   <dependency>
>     <uri>oracle/jars/classes12.zip</uri>
>   </dependency>
>
> I tried to change to the followings, and even rename the oracle\jars to
> oracle\zips:
>
>   <dependency>
>     <uri>oracle/classes12/jar</uri>
>   </dependency>
>
>
>   <dependency>
>     <uri>oracle/classes12/zip</uri>
>   </dependency>
>
> But I always get the following error when I deploy using deploy.bat:
>
>     Error: Unable to distribute tranql-connector-1.1.rar:
>     org.apache.geronimo.kernel.repository.MissingDependencyException:
>     uri oracle/classes12/zip not found in repository
>
>         uri oracle/classes12/zip not found in repository
>
> What is the right uri syntax if the JDBC driver is a zip file?
>
>
>
> thanks,
>
> Lin
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>

Mime
View raw message