geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Jencks <david_jen...@yahoo.com>
Subject Re: How do I convert this dependency in AG 1.0
Date Sat, 14 Jan 2006 18:08:37 GMT
I think you need to rename the jar to have a maven-recognizable  
version, i.e. there is a '-' before the version.  If you want to keep  
it as a zip file I think you could use the uri

oracle/classes12/10gr2/zip

and put the file in repository/oracle/zips/classes12-10gr2.zip

This doesn't seem entirely satisfactory.  Perhaps we need to find a  
way to "link" to the actual original files while also providing a  
versioned uri.

Hope this helps

david jencks

On Jan 13, 2006, at 6:30 PM, Lin Sun wrote:

> Yes that would work, but I don't want to rename my classes12.jar to  
> classes12-10g.jar if
> I don't have to.  Also, I cannot use the classes12.zip file either  
> because the file name
> ends with .zip.
>
> --- Jian Liao <norwaywoods@gmail.com> wrote:
>
>> Try this:
>> repository/oracle/jars/classes12-10gr2.jar
>>
>> and
>>
>> <dependency>
>>                 <uri>oracle/classes12/10gr2/jar</uri>
>> </dependency>
>>
>> Hope it helps,
>>
>> - Jian Liao
>>
>> On 1/12/06, Lin Sun <linsun_unc@yahoo.com> wrote:
>>>
>>> Hi there,
>>>
>>> I have a database deployment plan for Oracle database server.  It  
>>> worked
>>> well in Geronimo
>>> M5 using the generic tranql resource adapter .  I understand the
>>> dependency uri syntax is
>>> changed in Geronimo 1.0.   But i haven't been able to deploy the  
>>> database
>>> deployment plan
>>> in Geronimo 1.0 yet with different tries.
>>>
>>> In my repository I have file: oracle\jars\classes12.zip
>>>
>>> The dependency elements that worked with Geronimo M5:
>>>   <dependency>
>>>     <uri>oracle/jars/classes12.zip</uri>
>>>   </dependency>
>>>
>>> I tried to change to the followings, and even rename the oracle 
>>> \jars to
>>> oracle\zips:
>>>
>>>   <dependency>
>>>     <uri>oracle/classes12/jar</uri>
>>>   </dependency>
>>>
>>>
>>>   <dependency>
>>>     <uri>oracle/classes12/zip</uri>
>>>   </dependency>
>>>
>>> But I always get the following error when I deploy using deploy.bat:
>>>
>>>     Error: Unable to distribute tranql-connector-1.1.rar:
>>>      
>>> org.apache.geronimo.kernel.repository.MissingDependencyException:
>>>     uri oracle/classes12/zip not found in repository
>>>
>>>         uri oracle/classes12/zip not found in repository
>>>
>>> What is the right uri syntax if the JDBC driver is a zip file?
>>>
>>>
>>>
>>> thanks,
>>>
>>> Lin
>>>
>>> __________________________________________________
>>> Do You Yahoo!?
>>> Tired of spam?  Yahoo! Mail has the best spam protection around
>>> http://mail.yahoo.com
>>>
>>
>
>
> thanks,
>
> Lin
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com


Mime
View raw message