geronimo-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sachin Patel <sppat...@gmail.com>
Subject Re: Error publishing to geronimo with the current eclipse plugin
Date Sun, 29 Jan 2006 20:02:01 GMT
Yes, the plugin is required to run on 1.4.2.

- sachin



On Jan 29, 2006, at 12:16 PM, Richard Kennedy wrote:

> Hi,
> I'm having similar problems with this.
>
> I'm running on linux AMD64 with the jdk1.50_06 -
>
> running eclipse on java 1.5.0_06 (64bit) & starting geronimo on 1.4.2
> (32bit)
>
> In the geronimo console viewing the server/jvm info I see :
>         java.library.path
>         /usr/java/j2sdk1.4.2_10/jre/lib/i386/client
>         /usr/java/j2sdk1.4.2_10/jre/lib/i386
>         /usr/java/j2sdk1.4.2_10/jre/../lib/i386
>         /usr/java/jdk1.5.0_06/jre/lib/amd64/server
>         /usr/java/jdk1.5.0_06/jre/lib/amd64
>         /usr/java/jdk1.5.0_06/jre/../lib/amd64
>         /usr/lib64
>
> Also the environment for the geronimo process contains
> JAVA_HOME=/usr/java/jdk1.5.0_06, which is set in my default env.
>
> and the failed deployment exception in the geronimo log
> ERROR [Deployer] Deployment failed due to
> java.lang.UnsupportedClassVersionError: rsk/gero1/test1  
> (Unsupported major.minor version 49.0)
>         at java.lang.ClassLoader.defineClass0(Native Method)
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
>         at java.security.SecureClassLoader.defineClass 
> (SecureClassLoader.java:123)
>         at java.net.URLClassLoader.defineClass(URLClassLoader.java: 
> 251)
>         at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
>         at  
> org.apache.geronimo.kernel.config.MultiParentClassLoader.loadClass 
> (MultiParentClassLoader.java:209)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
>         at  
> org.apache.geronimo.naming.deployment.ENCConfigBuilder.assureInterface 
> (ENCConfigBuilder.java:664)
>         at  
> org.apache.geronimo.naming.deployment.ENCConfigBuilder.assureEJBObject 
> Interface(ENCConfigBuilder.java:643)
>
> So I'm guessing that having both 1.4.2 & 1.5.0 components and a mix of
> 32 & 64 bit in the java.library.path is a bad thing :(
>
> Any ideas how I can get around this? or should I drop back to the  
> 32bit
> eclipse & jdk 1.4.2?
>
> Cheers
> Richard
>
>


Mime
View raw message